summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 02:19:50 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 02:47:38 -0500
commita134a699ff3f7d86590e6852999f30ab4d7e275d (patch)
tree4032c5444b9b4ce59c68bcd6de8c12b177f80086 /games-fps
parentgames-fps/unreal-tournament-bonuspacks: EAPI=5 (diff)
downloadgentoo-a134a699ff3f7d86590e6852999f30ab4d7e275d.tar.gz
gentoo-a134a699ff3f7d86590e6852999f30ab4d7e275d.tar.bz2
gentoo-a134a699ff3f7d86590e6852999f30ab4d7e275d.zip
games-fps/unreal-tournament-strikeforce: EAPI=5
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild
index 02de93e690fd..1b068f86dddc 100644
--- a/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild
+++ b/games-fps/unreal-tournament-strikeforce/unreal-tournament-strikeforce-1.81.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
inherit games
MY_PV=${PV/./}
@@ -31,16 +32,16 @@ src_unpack() {
unpack sf_180_server_files.tar.gz
unpack ${P}.tar.bz2
unpack sf180lnx.zip
- mv "README - sf orm mappack.txt" Strikeforce/SFDoc/
- rm -rf Help/OpenGL\ Alternate
- rm System/*.{dll,lnk,exe} System/ServerAdds.zip
- rm Strikeforce/SF_System/*.bat
- find -type f -exec chmod a-x '{}' +
+ mv "README - sf orm mappack.txt" Strikeforce/SFDoc/ || die
+ rm -rf Help/OpenGL\ Alternate || die
+ rm System/*.{dll,lnk,exe} System/ServerAdds.zip || die
+ rm Strikeforce/SF_System/*.bat || die
+ find -type f -exec chmod a-x '{}' + || die
}
src_install() {
local dir=${GAMES_PREFIX_OPT}/unreal-tournament
dodir "${dir}"
- mv * "${D}/${dir}/"
+ mv * "${D}/${dir}/" || die
prepgamesdirs
}