summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 20:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 19:42:20 +0100
commitbe0ab352405aa2d5d968a8c3905557b914df9626 (patch)
tree5b5da6a6ab8feb0c82b1f5c6b02e9fafdee83463 /games-fps
parentsys-kernel/gentoo-sources: Linux patch 5.4.7 (diff)
downloadgentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.gz
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.tar.bz2
gentoo-be0ab352405aa2d5d968a8c3905557b914df9626.zip
*/*: Switch proxy-maint to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/gzdoom/gzdoom-4.2.4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-fps/gzdoom/gzdoom-4.2.4.ebuild b/games-fps/gzdoom/gzdoom-4.2.4.ebuild
index da843dc71ad1..f6844ab0cf13 100644
--- a/games-fps/gzdoom/gzdoom-4.2.4.ebuild
+++ b/games-fps/gzdoom/gzdoom-4.2.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils desktop xdg
+inherit cmake desktop xdg
DESCRIPTION="A modder-friendly OpenGL source port based on the DOOM engine"
HOMEPAGE="https://zdoom.org"
@@ -42,7 +42,7 @@ src_prepare() {
rm -rf wadsrc_bm wadsrc_extra || die
fi
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -59,13 +59,13 @@ src_configure() {
-DNO_OPENMP="$(usex !openmp)"
-DBUILD_NONFREE="$(usex nonfree)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
newicon src/posix/zdoom.xpm "${PN}.xpm"
make_desktop_entry "${PN}" "GZDoom" "${PN}" "Game;ActionGame"
- cmake-utils_src_install
+ cmake_src_install
}
pkg_postinst() {