summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 06:54:17 +0000
committerSam James <sam@gentoo.org>2021-04-04 07:21:42 +0000
commitf100f3cd2b585dce93f69116d82e61549b43c957 (patch)
treeb08d6ca3100d00d3efd648d561a4f870fc25a497 /games-fps
parentgames-board/xfreecell: port to EAPI 7, eutils->desktop (diff)
downloadgentoo-f100f3cd2b585dce93f69116d82e61549b43c957.tar.gz
gentoo-f100f3cd2b585dce93f69116d82e61549b43c957.tar.bz2
gentoo-f100f3cd2b585dce93f69116d82e61549b43c957.zip
games-fps/tenebrae: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/tenebrae/files/1.04-glhax.patch4
-rw-r--r--games-fps/tenebrae/files/tenebrae-1.04-redef.patch4
-rw-r--r--games-fps/tenebrae/tenebrae-1.04-r1.ebuild49
3 files changed, 28 insertions, 29 deletions
diff --git a/games-fps/tenebrae/files/1.04-glhax.patch b/games-fps/tenebrae/files/1.04-glhax.patch
index a185d8e10c7d..ffabf36f1768 100644
--- a/games-fps/tenebrae/files/1.04-glhax.patch
+++ b/games-fps/tenebrae/files/1.04-glhax.patch
@@ -1,5 +1,5 @@
---- tenebrae_0/glquake.h 2004-12-25 00:28:28.707288592 -0500
-+++ tenebrae_0/glquake.h 2004-12-25 00:27:35.000000000 -0500
+--- a/glquake.h
++++ b/glquake.h
@@ -34,6 +34,7 @@
#else
#include <GL/gl.h>
diff --git a/games-fps/tenebrae/files/tenebrae-1.04-redef.patch b/games-fps/tenebrae/files/tenebrae-1.04-redef.patch
index 8bd89aa18e6f..abcfacec180c 100644
--- a/games-fps/tenebrae/files/tenebrae-1.04-redef.patch
+++ b/games-fps/tenebrae/files/tenebrae-1.04-redef.patch
@@ -1,5 +1,5 @@
---- a/sys_dosa.s 2017-09-06 16:41:31.875358788 -0500
-+++ b/sys_dosa.s 2017-09-06 16:41:35.947376646 -0500
+--- a/sys_dosa.s
++++ b/sys_dosa.s
@@ -44,6 +44,8 @@
.text
diff --git a/games-fps/tenebrae/tenebrae-1.04-r1.ebuild b/games-fps/tenebrae/tenebrae-1.04-r1.ebuild
index 85a7552e4015..07743ada8ed5 100644
--- a/games-fps/tenebrae/tenebrae-1.04-r1.ebuild
+++ b/games-fps/tenebrae/tenebrae-1.04-r1.ebuild
@@ -1,42 +1,41 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
#ECVS_SERVER="cvs.tenebrae.sourceforge.net:/cvsroot/tenebrae"
#ECVS_MODULE="tenebrae_0"
-#inherit cvs
-inherit eutils
-DESCRIPTION="adds stencil shadows and per pixel lights to quake"
+inherit toolchain-funcs
+
+DESCRIPTION="Adds stencil shadows and per pixel lights to quake"
HOMEPAGE="http://tenebrae.sourceforge.net/"
SRC_URI="mirror://sourceforge/tenebrae/tenebraedata.zip
mirror://gentoo/${P}.tbz2"
+S="${WORKDIR}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
RDEPEND="
+ media-libs/libpng:0
virtual/glu
virtual/opengl
- media-libs/libpng:0
x11-libs/libXxf86dga
- x11-libs/libXxf86vm"
-DEPEND="${RDEPEND}
- app-arch/unzip
- x11-base/xorg-proto"
-
-S=${WORKDIR}
+ x11-libs/libXxf86vm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="app-arch/unzip"
-src_unpack() {
- if [[ -z ${ECVS_MODULE} ]] ; then
- unpack ${A}
- else
- cvs_src_unpack
- fi
-}
+PATCHES=(
+ "${FILESDIR}"/${PV}-glhax.patch
+ "${FILESDIR}"/${P}-exec-stack.patch
+ "${FILESDIR}"/${P}-redef.patch
+)
src_prepare() {
cd tenebrae_0 || die "cd failed"
@@ -45,27 +44,27 @@ src_prepare() {
-e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:g' \
gl_warp.c || die
- eapply "${FILESDIR}"/${PV}-glhax.patch
- eapply "${FILESDIR}"/${P}-exec-stack.patch
- eapply "${FILESDIR}"/${P}-redef.patch
-
default
cd linux || die "cd failed"
sed \
-e "/^LDFLAGS/s:=:+=:" \
-e "s:-mpentiumpro -O6:${CFLAGS}:" \
+ -e "s:CC.*= /usr/bin/gcc:CC?=/usr/bin/gcc:" \
Makefile.i386linux > Makefile || die
}
src_compile() {
+ tc-export CC
+
cd "${S}"/tenebrae_0/linux || die "cd failed"
emake MASTER_DIR="/usr/share/quake1" build_release
}
src_install() {
newbin tenebrae_0/linux/release*/bin/tenebrae.run tenebrae
- insinto "/usr/share/quake1/tenebrae"
+
+ insinto /usr/share/quake1/tenebrae
doins "${WORKDIR}"/tenebrae/*
dodoc tenebrae_0/linux/README "${WORKDIR}"/Tenebrae_Readme.txt
}