summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/gcompris/files/gcompris-15.02-build.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/gcompris/files/gcompris-15.02-build.patch')
-rw-r--r--games-kids/gcompris/files/gcompris-15.02-build.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/games-kids/gcompris/files/gcompris-15.02-build.patch b/games-kids/gcompris/files/gcompris-15.02-build.patch
new file mode 100644
index 000000000000..077d1f6baf1a
--- /dev/null
+++ b/games-kids/gcompris/files/gcompris-15.02-build.patch
@@ -0,0 +1,81 @@
+--- gcompris-13.11.orig/Makefile.am
++++ gcompris-13.11/Makefile.am
+@@ -7,7 +7,7 @@
+ # endif
+
+
+-icondir=$(datadir)/pixmaps
++icondir=/usr/share/pixmaps
+ icon_DATA = gcompris.png gcompris-edit.png
+
+ if BUILD_MINGW32
+@@ -15,7 +15,7 @@
+ Applications_in_files =
+ Applications_DATA =
+ else
+-Applicationsdir = $(datadir)/applications/
++Applicationsdir = /usr/share/applications/
+ Applications_in_files = gcompris.desktop.in gcompris-edit.desktop.in
+ Applications_DATA = gcompris.desktop gcompris-edit.desktop
+ endif
+--- gcompris-13.11.orig/configure.ac
++++ gcompris-13.11/configure.ac
+@@ -57,7 +57,8 @@
+ gtk+-2.0 >= $GTK_REQUIRED \
+ librsvg-2.0 >= $LIBRSVG_REQUIRED \
+ libxml-2.0 >= $LIBXML_REQUIRED \
+- gthread-2.0 )
++ gthread-2.0 \
++ gmodule-2.0 )
+
+ AC_SUBST(GCOMPRIS_CFLAGS)
+ AC_SUBST(GCOMPRIS_LIBS)
+@@ -204,10 +205,8 @@
+ USE_DEBUG="$enableval", USE_DEBUG="no")
+ if test "x$USE_DEBUG" == "xyes" ; then
+ AC_DEFINE_UNQUOTED(DEBUG, 1, "Enable debug messages.")
+- CFLAGS="$CFLAGS $OSX_CFLAGS -Wall -g"
+-else
+- CFLAGS="$CFLAGS $OSX_CFLAGS -Wall -O2"
+ fi
++CFLAGS="$CFLAGS $OSX_CFLAGS -Wall"
+
+ dnl disable activation code
+ AC_ARG_ENABLE(disable-activation-code,
+@@ -336,21 +335,21 @@
+ fi
+ else
+ dnl Set PACKAGE_LOCALE_DIR in config.h.
+- AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "${myprefix}/${DATADIRNAME}/locale", [GCompris locale directory])
++ AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "/usr/share/locale", [GCompris locale directory])
+
+ dnl Set PACKAGE_DATA_DIR
+ PACKAGE_DATA_DIR="boards"
+ AC_SUBST(PACKAGE_DATA_DIR)
+- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${myprefix}/${DATADIRNAME}", [GCompris data directory])
++ AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datadir}", [GCompris data directory])
+
+ dnl Plugin Directory
+ my_libdir=`eval echo "${libdir}"`
+- AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "${my_libdir}", [Gcompris plugins directory])
++ AC_DEFINE_UNQUOTED(PACKAGE_CLIB_DIR, "${libdir}", [Gcompris plugins directory])
+ plugindir=$libdir/gcompris
+ AC_SUBST(plugindir)
+
+ dnl Python plugin Directory
+- PYTHON_PLUGIN_DIR="${myprefix}/${DATADIRNAME}/${PACKAGE}/python"
++ PYTHON_PLUGIN_DIR="${datadir}/${PACKAGE}/python"
+ AC_SUBST(PYTHON_PLUGIN_DIR)
+
+ dnl System GCompris config directory
+--- gcompris-13.11.orig/src/gcompris/gcompris.c
++++ gcompris-13.11/src/gcompris/gcompris.c
+@@ -1322,7 +1322,7 @@
+ properties->package_plugin_dir = g_strconcat(pkg_clib_dir, "/gcompris", NULL);
+ properties->package_python_plugin_dir = g_strconcat(pkg_data_dir, "/gcompris/python",
+ NULL);
+- properties->system_icon_dir = g_strconcat(pkg_data_dir, "/pixmaps", NULL);
++ properties->system_icon_dir = g_strconcat("/usr/share", "/pixmaps", NULL);
+ properties->menu_dir = g_strdup(properties->package_data_dir);
+ g_free(pkg_data_dir);
+ g_free(pkg_clib_dir);