summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/tuxmath
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/tuxmath')
-rw-r--r--games-kids/tuxmath/Manifest1
-rw-r--r--games-kids/tuxmath/metadata.xml8
-rw-r--r--games-kids/tuxmath/tuxmath-2.0.1.ebuild73
3 files changed, 82 insertions, 0 deletions
diff --git a/games-kids/tuxmath/Manifest b/games-kids/tuxmath/Manifest
new file mode 100644
index 000000000000..564780819f85
--- /dev/null
+++ b/games-kids/tuxmath/Manifest
@@ -0,0 +1 @@
+DIST tuxmath_w_fonts-2.0.1.tar.gz 10448109 SHA256 6d26c08672edf5cce0ef2f685555867a7016c8a186282518276378b6c58774f4 SHA512 04f6c347a5eecca7790b5577a9dcb3ea7bf444e19614b468ba6902e37c25aa7de22c62f7ab34e6bd282326f443496aa1d8320f13c4d12ec7e14c118e519e4dc7 WHIRLPOOL a4749d547651ccc9ddd6a36bdf928e751e36ec03678e4955a80fb24a45a466a1c390dcd0ddb8e006437c1c5e6a2c27e4b47cca0da86a484bde292e4699ce50d7
diff --git a/games-kids/tuxmath/metadata.xml b/games-kids/tuxmath/metadata.xml
new file mode 100644
index 000000000000..8e44372ac61b
--- /dev/null
+++ b/games-kids/tuxmath/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">tuxmath</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-kids/tuxmath/tuxmath-2.0.1.ebuild b/games-kids/tuxmath/tuxmath-2.0.1.ebuild
new file mode 100644
index 000000000000..89718b6a1300
--- /dev/null
+++ b/games-kids/tuxmath/tuxmath-2.0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+MY_PN="${PN}_w_fonts"
+DESCRIPTION="Educational arcade game where you have to solve maths problems"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/"
+SRC_URI="mirror://sourceforge/tuxmath/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls svg"
+
+RDEPEND="dev-games/t4k-common[svg?]
+ dev-libs/libxml2:2
+ media-libs/libsdl:0
+ media-libs/sdl-pango
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]
+ media-libs/sdl-net
+ nls? ( virtual/libintl )
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ sed -i \
+ -e '/\bdoc\b/d' \
+ Makefile.in || die
+ sed -i \
+ -e '/strncat/s/)/ - 1)/' \
+ src/server.c || die
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ $(use_enable nls) \
+ $(usex svg "" "--without-rsvg")
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon -s scalable data/images/icons/${PN}.svg
+ make_desktop_entry ${PN} "TuxMath"
+ dodoc doc/{README,TODO,changelog}
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}