summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 21:27:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-02 21:30:55 +0100
commitc8e8439ae213069f2c497fa8f7b54bf48a2563f9 (patch)
treeebaf0c3b4d57c642d5196c9c7b4d184360837c89 /games-kids
parentsci-libs/cfitsio: 3.490 version bump (diff)
downloadgentoo-c8e8439ae213069f2c497fa8f7b54bf48a2563f9.tar.gz
gentoo-c8e8439ae213069f2c497fa8f7b54bf48a2563f9.tar.bz2
gentoo-c8e8439ae213069f2c497fa8f7b54bf48a2563f9.zip
games-kids/gcompris: 1.0 version bump
Closes: https://bugs.gentoo.org/756175 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/Manifest1
-rw-r--r--games-kids/gcompris/gcompris-1.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/games-kids/gcompris/Manifest b/games-kids/gcompris/Manifest
index 657ef5316634..45ec459f906d 100644
--- a/games-kids/gcompris/Manifest
+++ b/games-kids/gcompris/Manifest
@@ -1 +1,2 @@
DIST gcompris-qt-0.97.tar.xz 75362060 BLAKE2B e6bc429ba4a8a622792935c9b2e68149f5c1f4d9aae4cac84ca517ebe83e59a9b4307f6ce84b36e658256cad5c8bd37b7cbc60a058b6d65be372ad1934cf666f SHA512 23cc807238121a6ea3abb8816795b2f3b243c3be1acf782705468d92758a2032a8cb5393c3c30028877d174ff53ebc3a62f69e9045bc70a5281d1d245b6e4eba
+DIST gcompris-qt-1.0.tar.xz 75856376 BLAKE2B d10e1c7f80d45214fea11e221cc6cc8910ddbc3446f431279b8047103b51ffe3dbcda387908bb3a66e383383ea83f85f350c1b7c3468420dea668764672422fa SHA512 8ba89035f9e332b375808f3ba228f8ff211ef08a8edc0637399b5d00cd99120700c89e01c2e5ebd5e90a958229f34034f11c1bbdba044381005f588252af3c86
diff --git a/games-kids/gcompris/gcompris-1.0.ebuild b/games-kids/gcompris/gcompris-1.0.ebuild
new file mode 100644
index 000000000000..06d26a0dc3a6
--- /dev/null
+++ b/games-kids/gcompris/gcompris-1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Full featured educational application for children from 2 to 10"
+HOMEPAGE="https://gcompris.net/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="https://gcompris.net/download/qt/src/${PN}-qt-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-qt-${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="kiosk"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ test? (
+ dev-util/cppcheck
+ sys-devel/clang
+ )
+"
+COMMON_DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtsensors-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer,qml]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQML_BOX2D_MODULE=disabled
+ -DWITH_KIOSK_MODE=$(usex kiosk)
+ )
+ ecm_src_configure
+}