summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-26 21:58:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-26 22:16:48 +0100
commit426034620ff4dcb16a4b10f814530923bacb34b4 (patch)
treec68af20edc2d33070d8406ceeb29024efee9335d /games-misc/opengfx
parentgames-util/grfcodec: add ~arm64 and ~ppc keyword (diff)
downloadgentoo-426034620ff4dcb16a4b10f814530923bacb34b4.tar.gz
gentoo-426034620ff4dcb16a4b10f814530923bacb34b4.tar.bz2
gentoo-426034620ff4dcb16a4b10f814530923bacb34b4.zip
games-misc/opengfx: bump to version 0.6.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-misc/opengfx')
-rw-r--r--games-misc/opengfx/Manifest1
-rw-r--r--games-misc/opengfx/opengfx-0.6.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/games-misc/opengfx/Manifest b/games-misc/opengfx/Manifest
index cb8f5b3a92a8..268fa543ff23 100644
--- a/games-misc/opengfx/Manifest
+++ b/games-misc/opengfx/Manifest
@@ -1,2 +1,3 @@
DIST opengfx-0.5.4-source.tar.xz 9638204 BLAKE2B bff7e5f7f72b62584c280ce2af2ad53df40027a7075ea5858a53f45a71be07db480cf61a603fc8e5df69b8c7d73284bf92e430a3fe130ae34ad1a921d8603925 SHA512 42f8438c747b42a77cf9d86c5da60ce3ce84ed347d714c345f3871806f9e35f2ed4729b445e0ee319f3e2edd53458dfbaad5ca42e389c3a2e800bce19223cdb1
DIST opengfx-0.5.5-source.tar.xz 9639584 BLAKE2B 49af829802adf3756e89728697ea796b98422bd0e314cd21d34910f8f7428963c2d4799a933e861ae344a2e83dd748289bbe501bccb77aba647b484ed07de376 SHA512 952fb52e19bd790e335a9df0f11fa29b2fc570b49903419904956cc65883adde93d432160b16682366ab8b973b7852d2d30f574f1840f6fbd082e1addbe5bfe8
+DIST opengfx-0.6.0-source.tar.xz 9693320 BLAKE2B cb1d25fb038b3b481c0abe206426b5843c2f7b81b7cf81a525ebf8b217359c5ea50c0e1ee1ed37d5093a0186231a1e1b9134624a8b69362f6733c6c13d5e1500 SHA512 275b9040e6938bdd5bee2d39361e0b78f447a8e497cc8ff018c7874dc16a357870f8b560999ebb2f2f0b275644c7c9ce85c964875f5a798e2ec45e62a8bc768f
diff --git a/games-misc/opengfx/opengfx-0.6.0.ebuild b/games-misc/opengfx/opengfx-0.6.0.ebuild
new file mode 100644
index 000000000000..7e39ffe5a490
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="OpenGFX"
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="https://cdn.openttd.org/${PN}-releases/${PV}/${P}-source.tar.xz"
+S="${WORKDIR}/${P}-source"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="
+ games-util/grfcodec
+ games-util/nml
+"
+
+DOCS=( "README.md" "changelog.txt" )
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ myemakeargs=(
+ GIMP=""
+ )
+
+ emake "${myemakeargs[@]}" all
+}
+
+src_test() {
+ myemakeargs=(
+ GIMP=""
+ )
+
+ emake "${myemakeargs[@]}" check
+}
+
+src_install() {
+ myemakeargs=(
+ DO_NOT_INSTALL_README="true"
+ DO_NOT_INSTALL_LICENSE="true"
+ DO_NOT_INSTALL_CHANGELOG="true"
+ GIMP=""
+ INSTALL_DIR="${ED}/usr/share/games/openttd/data/"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ einstalldocs
+}