summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Golubev <fatzer2@gmail.com>2016-12-26 01:39:18 +0300
committerLars Wendler <polynomial-c@gentoo.org>2016-12-26 18:04:47 +0100
commit166867ba72aded7a12c1b98fd263eac056d495c6 (patch)
tree08a2a7e99879c59d6b7946e0017f2624a198bf89 /games-misc/openmsx
parentgames-misc/opengfx: EAPI=6 (diff)
downloadgentoo-166867ba72aded7a12c1b98fd263eac056d495c6.tar.gz
gentoo-166867ba72aded7a12c1b98fd263eac056d495c6.tar.bz2
gentoo-166867ba72aded7a12c1b98fd263eac056d495c6.zip
games-misc/openmsx: EAPI=6
Closes: https://github.com/gentoo/gentoo/pull/3242
Diffstat (limited to 'games-misc/openmsx')
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-misc/openmsx/openmsx-0.3.1-r2.ebuild b/games-misc/openmsx/openmsx-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..53582e34ee4c
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+DESCRIPTION="An ambiguously named music replacement set for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/openmsx/"
+SRC_URI="http://bundles.openttdcoop.org/openmsx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+S=${WORKDIR}/${P}-source
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_compile() {
+ emake _V= bundle || die
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/gm/${P}"
+ doins ${P}/{*.mid,openmsx.obm} || die
+ dodoc ${P}/{changelog.txt,readme.txt} || die
+}