summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/xcruiser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/xcruiser')
-rw-r--r--games-misc/xcruiser/Manifest1
-rw-r--r--games-misc/xcruiser/metadata.xml8
-rw-r--r--games-misc/xcruiser/xcruiser-0.30.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/games-misc/xcruiser/Manifest b/games-misc/xcruiser/Manifest
new file mode 100644
index 000000000000..d105edcbe747
--- /dev/null
+++ b/games-misc/xcruiser/Manifest
@@ -0,0 +1 @@
+DIST xcruiser-0.30.tar.gz 38667 SHA256 917b68dc06389bfcdde742f0798f61cdeaea2ae3c6567960c33f7634d4861ce5 SHA512 77f1dbfd4497e30bb1ee0f41121a6f85cd1bf2b59fc542e88326bded8b806ecd7439689765a73ea88215c768a3bdca1370ae80b956de38a131b927b6af9e674b WHIRLPOOL 7dc4ad1013c629198f311857f2deecaaae178ef164d800c511d59718ab19cd137d8010c104c4ecdc94dcc4f32a2402777189384df220ada06f0b67592bcfafce
diff --git a/games-misc/xcruiser/metadata.xml b/games-misc/xcruiser/metadata.xml
new file mode 100644
index 000000000000..1a97e4bca997
--- /dev/null
+++ b/games-misc/xcruiser/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">xcruiser</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/xcruiser/xcruiser-0.30.ebuild b/games-misc/xcruiser/xcruiser-0.30.ebuild
new file mode 100644
index 000000000000..c25aa07477fc
--- /dev/null
+++ b/games-misc/xcruiser/xcruiser-0.30.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Fly about 3D-formed file system"
+HOMEPAGE="http://xcruiser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="x11-libs/libXaw
+ x11-libs/libXp"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_compile() {
+ xmkmf -a
+ emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xcruiser
+ dodoc CHANGES README README.jp TODO
+ newman xcruiser.man xcruiser.1
+}