summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-01 16:54:39 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-01 16:54:39 -0500
commit42adde8586669fc97cc9026d17bfa79484434822 (patch)
treee1d8ea045a9a1f37b56b0e35667287745806895f /games-misc
parentnet-wireless/horst: TODO was removed. (diff)
downloadgentoo-42adde8586669fc97cc9026d17bfa79484434822.tar.gz
gentoo-42adde8586669fc97cc9026d17bfa79484434822.tar.bz2
gentoo-42adde8586669fc97cc9026d17bfa79484434822.zip
version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/robotfindskitten/Manifest1
-rw-r--r--games-misc/robotfindskitten/files/robotfindskitten-2.7182818.701-gentoo.patch24
-rw-r--r--games-misc/robotfindskitten/robotfindskitten-2.7182818.701.ebuild30
3 files changed, 55 insertions, 0 deletions
diff --git a/games-misc/robotfindskitten/Manifest b/games-misc/robotfindskitten/Manifest
index 095f9ead88b7..3c8d8e07f371 100644
--- a/games-misc/robotfindskitten/Manifest
+++ b/games-misc/robotfindskitten/Manifest
@@ -1 +1,2 @@
DIST robotfindskitten-1.7320508.406.tar.gz 406412 SHA256 08c8a826c3cf90a7f3dc1d42b087425af661971585f125b9bedca2bcc2a11852 SHA512 96c8f9968336cda5f079ca4b69a17a76444a3291b1354d594d2a9b89cb0d88296b983c70076da3334774710d811b33a90fe513ba5dca330808e5345e6c920865 WHIRLPOOL 6a60e847d96db16cee9e2a2788ee412c9cf3fc859af164f5e281d4180fad7d9001fb36a58e0ae75a149fe8229780a7024d5dc5f5eb71c9b272c878f87d44312f
+DIST robotfindskitten-2.7182818.701.tar.gz 437810 SHA256 7749a370796fd23e3b306b00de5f7fb7997a35fef30e3910ff159448c932d719 SHA512 736e44a62f016fb2a0dd03e31e6f1fb7c50a9115182812518666f3e4ad69f5703d7018f28ab14e0cfdbc8741656b15fa6ee577c2a5920e0d9af9acb658ac620b WHIRLPOOL f29092a17d5e13c8d9f578e318edf5045bd478c6c4e3ae4f05258ebc4be10736b9bc71e8ab55a287e7accee6f3606a18a4d475c09dbfa59a6bb029e548225d2a
diff --git a/games-misc/robotfindskitten/files/robotfindskitten-2.7182818.701-gentoo.patch b/games-misc/robotfindskitten/files/robotfindskitten-2.7182818.701-gentoo.patch
new file mode 100644
index 000000000000..6f5aa29a9f51
--- /dev/null
+++ b/games-misc/robotfindskitten/files/robotfindskitten-2.7182818.701-gentoo.patch
@@ -0,0 +1,24 @@
+--- robotfindskitten-2.7182818.701.orig/nki/Makefile.in
++++ robotfindskitten-2.7182818.701/nki/Makefile.in
+@@ -197,7 +197,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-nkidir = $(datadir)/games/robotfindskitten
++nkidir = $(datadir)/robotfindskitten
+ nki_DATA = vanilla.nki
+ all: all-am
+
+--- robotfindskitten-2.7182818.701.orig/src/Makefile.in
++++ robotfindskitten-2.7182818.701/src/Makefile.in
+@@ -199,8 +199,8 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-execgamesdir = $(prefix)/games
+-AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/games/robotfindskitten\"
++execgamesdir = $(bindir)
++AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/robotfindskitten\"
+ robotfindskitten_SOURCES = robotfindskitten.c
+ SPLINT_SUPPRESSIONS = +charintliteral +charindex
+ all: all-am
diff --git a/games-misc/robotfindskitten/robotfindskitten-2.7182818.701.ebuild b/games-misc/robotfindskitten/robotfindskitten-2.7182818.701.ebuild
new file mode 100644
index 000000000000..ae170bc90f7b
--- /dev/null
+++ b/games-misc/robotfindskitten/robotfindskitten-2.7182818.701.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Help robot find kitten"
+HOMEPAGE="http://robotfindskitten.org/"
+SRC_URI="mirror://sourceforge/rfk/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS" \
+ default
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins nki/vanilla.nki
+ prepgamesdirs
+}