summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-27 22:59:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:10 +0100
commit55529e0658274200a9c56e7330c7843e10afa25a (patch)
tree0cfbdebe7eaf9a15e675208240351febb9a2b5f3 /games-misc
parentgames-kids/memonix: EAPI-7 bump, cmake.eclass, https, drop eutils (diff)
downloadgentoo-55529e0658274200a9c56e7330c7843e10afa25a.tar.gz
gentoo-55529e0658274200a9c56e7330c7843e10afa25a.tar.bz2
gentoo-55529e0658274200a9c56e7330c7843e10afa25a.zip
games-misc/ballerburg: EAPI-7 bump, cmake.eclass, https
Use nomancompress.patch and drop src_install. Need to set CMAKE_MAKEFILE_GENERATOR=emake, otherwise ninja fails with: ninja: error: '/var/tmp/portage/games-misc/ballerburg-1.2.0-r1/work/ballerburg-1.2.0/src/*.c', needed by 'po/ballerburg.pot', missing and no known rule to make it Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild20
-rw-r--r--games-misc/ballerburg/files/ballerburg-1.2.0-nomancompress.patch12
2 files changed, 21 insertions, 11 deletions
diff --git a/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild b/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
index e4a987433010..6b15169bd6a3 100644
--- a/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
+++ b/games-misc/ballerburg/ballerburg-1.2.0-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+CMAKE_MAKEFILE_GENERATOR=emake
+inherit cmake
DESCRIPTION="Linux port of the classical Atari ST game Ballerburg"
-HOMEPAGE="http://baller.tuxfamily.org/"
-SRC_URI="http://download.tuxfamily.org/baller/${P}.tar.gz"
+HOMEPAGE="https://baller.tuxfamily.org/"
+SRC_URI="https://download.tuxfamily.org/baller/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
@@ -16,14 +17,11 @@ KEYWORDS="~amd64"
DEPEND="media-libs/libsdl"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-nomancompress.patch" )
+
src_configure() {
local mycmakeargs=(
-DDOCDIR=share/doc/${PF}
)
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- gunzip "${ED}usr/share/man/man6/ballerburg.6.gz" || die
+ cmake_src_configure
}
diff --git a/games-misc/ballerburg/files/ballerburg-1.2.0-nomancompress.patch b/games-misc/ballerburg/files/ballerburg-1.2.0-nomancompress.patch
new file mode 100644
index 000000000000..1d12b1b82e1f
--- /dev/null
+++ b/games-misc/ballerburg/files/ballerburg-1.2.0-nomancompress.patch
@@ -0,0 +1,12 @@
+--- a/doc/CMakeLists.txt 2015-03-29 17:04:01.000000000 +0200
++++ b/doc/CMakeLists.txt 2021-02-27 22:56:13.025989166 +0100
+@@ -1,8 +1,3 @@
+
+ INSTALL(FILES de/anleitung.html en/manual.html DESTINATION ${DOCDIR})
+-
+-add_custom_target(manpages ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/ballerburg.6.gz)
+-add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/ballerburg.6.gz
+- COMMAND gzip -c -9 ${CMAKE_CURRENT_SOURCE_DIR}/ballerburg.6 > ${CMAKE_CURRENT_BINARY_DIR}/ballerburg.6.gz
+- DEPENDS ballerburg.6)
+-INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/ballerburg.6.gz DESTINATION ${MANDIR})
++INSTALL(FILES ballerburg.6 DESTINATION ${MANDIR})