summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 08:09:01 +0100
committerSam James <sam@gentoo.org>2022-10-04 08:09:26 +0100
commit76df52808527b029935ffd66511d4adda0c2e46d (patch)
tree781a12463bc707422665c50b27af3a9a422c36ce /games-misc
parentmedia-video/blinkensim: fix configure issues with Clang 16 (diff)
downloadgentoo-76df52808527b029935ffd66511d4adda0c2e46d.tar.gz
gentoo-76df52808527b029935ffd66511d4adda0c2e46d.tar.bz2
gentoo-76df52808527b029935ffd66511d4adda0c2e46d.zip
games-misc/gBhed: EAPI 8, fix configure issues with Clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/gBhed/gBhed-0.17-r2.ebuild (renamed from games-misc/gBhed/gBhed-0.17-r1.ebuild)16
1 files changed, 9 insertions, 7 deletions
diff --git a/games-misc/gBhed/gBhed-0.17-r1.ebuild b/games-misc/gBhed/gBhed-0.17-r2.ebuild
index 30e33c085ccd..2ea96ea67eb6 100644
--- a/games-misc/gBhed/gBhed-0.17-r1.ebuild
+++ b/games-misc/gBhed/gBhed-0.17-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit desktop
+inherit autotools desktop
DESCRIPTION="An Al Bhed translator"
HOMEPAGE="http://liquidchile.net/software/gbhed/"
@@ -12,21 +12,23 @@ SRC_URI="http://liquidchile.net/software/gbhed/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="gtk"
+IUSE="gui"
-DEPEND="gtk? ( x11-libs/gtk+:2 )"
+DEPEND="gui? ( x11-libs/gtk+:2 )"
RDEPEND="${DEPEND}"
src_prepare() {
default
sed -i 's/19/32/' src/gui/translation_fork.c || die
+
+ eautoreconf
}
src_configure() {
econf \
--datadir=/usr/share/${PN} \
- $(use_enable gtk gbhed)
+ $(use_enable gui gbhed)
}
src_install() {
@@ -34,7 +36,7 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
doman doc/abtranslate.1
- if use gtk ; then
+ if use gui ; then
insinto /usr/share/${PN}/pixmaps
doins pixmaps/*.{jpg,png,xpm}