summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 05:48:45 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:52 +0300
commita42fa929921308e8acb987add3f17c04d92e36c4 (patch)
treea8cb6fb757b998993a01d8684244ff91aa039388 /games-misc
parentgames-board/xskat: fix build with -native-symlinks (diff)
downloadgentoo-a42fa929921308e8acb987add3f17c04d92e36c4.tar.gz
gentoo-a42fa929921308e8acb987add3f17c04d92e36c4.tar.bz2
gentoo-a42fa929921308e8acb987add3f17c04d92e36c4.zip
games-misc/xcruiser: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/730804 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/xcruiser/xcruiser-0.30-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/games-misc/xcruiser/xcruiser-0.30-r1.ebuild b/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
index c5f7a85927f4..154660e87178 100644
--- a/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
+++ b/games-misc/xcruiser/xcruiser-0.30-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,11 +18,15 @@ RDEPEND="x11-libs/libXaw"
DEPEND="${RDEPEND}
app-text/rman
x11-misc/gccmakedep
- x11-misc/imake"
+ >=x11-misc/imake-1.0.8-r1"
+
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+}
src_compile() {
- xmkmf -a
- emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}"
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}"
}
src_install() {