summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-04-29 18:50:08 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-04-29 21:30:02 +0200
commitaba9756e0148dc22c6e9e9cdc9324987ad4787e1 (patch)
tree36b33f8ae02ca292303157aa8dca242479ba8255 /games-misc
parentgames-util/nml: Add pythn3_9 to PYTHON_COMPAT (diff)
downloadgentoo-aba9756e0148dc22c6e9e9cdc9324987ad4787e1.tar.gz
gentoo-aba9756e0148dc22c6e9e9cdc9324987ad4787e1.tar.bz2
gentoo-aba9756e0148dc22c6e9e9cdc9324987ad4787e1.zip
games-misc/openmsx: Add python3_9 to PYTHON_COMPAT
Also move Python to BDEPEND. Closes: https://github.com/gentoo/gentoo/pull/20600 Closes: https://bugs.gentoo.org/786900 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-misc/openmsx/openmsx-0.3.1-r5.ebuild b/games-misc/openmsx/openmsx-0.3.1-r5.ebuild
new file mode 100644
index 000000000000..8e63fcc6ab4c
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-any-r1
+
+DESCRIPTION="Open source music base set for OpenTTD"
+HOMEPAGE="https://wiki.openttd.org/OpenMSX https://github.com/OpenTTD/OpenMSX"
+SRC_URI="https://cdn.openttd.org/openmsx-releases/${PV}/${P}-source.tar.gz"
+S="${WORKDIR}/${P}-source"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_compile() {
+ emake _V= bundle
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/gm/${P}"
+ doins ${P}/{*.mid,openmsx.obm}
+ dodoc ${P}/{changelog.txt,readme.txt}
+}