summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-18 19:05:28 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-18 19:05:50 -0500
commitfe8ae96aab9938fce8c3e5b155026980ce192ba9 (patch)
treeb768d786820e719380e54d826573cd18cd252145 /games-misc
parentsys-fs/btrfs-progs: older asciidoc fails to build docbookxml. (diff)
downloadgentoo-fe8ae96aab9938fce8c3e5b155026980ce192ba9.tar.gz
gentoo-fe8ae96aab9938fce8c3e5b155026980ce192ba9.tar.bz2
gentoo-fe8ae96aab9938fce8c3e5b155026980ce192ba9.zip
games-misc/OilWar: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/OilWar/OilWar-1.2.1-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-misc/OilWar/OilWar-1.2.1-r2.ebuild b/games-misc/OilWar/OilWar-1.2.1-r2.ebuild
new file mode 100644
index 000000000000..62f70006d01b
--- /dev/null
+++ b/games-misc/OilWar/OilWar-1.2.1-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils user
+
+DESCRIPTION="Evil army is attacking your country and tries to steal your oil"
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/RTS/OilWar-15354.shtml"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+pkg_setup(){
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CXXCOMPILE/s:$(CPPFLAGS):$(SDL_CFLAGS):' \
+ -e '/install-data-am:/s:\\::' \
+ -e '/install-data-local$/d' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf --enable-sound
+}
+
+src_install() {
+ default
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry oilwar ${PN}
+
+ fowners root:gamestat /usr/bin/oilwar /var/games/oilwar.scores
+ fperms 664 /var/games/oilwar.scores
+ fperms 2755 /usr/bin/oilwar
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}