summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 14:42:18 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commitd9816d84236c26c3a86a8f34d542edb35061e87d (patch)
treeda9ad45ad711235d18adffc4d9de4fb2150da976 /games-mud/trebuchet
parentgames-mud/tkmoo: remove deprecated games eclass (diff)
downloadgentoo-d9816d84236c26c3a86a8f34d542edb35061e87d.tar.gz
gentoo-d9816d84236c26c3a86a8f34d542edb35061e87d.tar.bz2
gentoo-d9816d84236c26c3a86a8f34d542edb35061e87d.zip
games-mud/trebuchet: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud/trebuchet')
-rw-r--r--games-mud/trebuchet/trebuchet-1.075-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-mud/trebuchet/trebuchet-1.075-r1.ebuild b/games-mud/trebuchet/trebuchet-1.075-r1.ebuild
new file mode 100644
index 000000000000..b8c40d882ad5
--- /dev/null
+++ b/games-mud/trebuchet/trebuchet-1.075-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A crossplatform TCL/TK based MUD client"
+HOMEPAGE="http://belfry.com/fuzzball/trebuchet/"
+SRC_URI="mirror://sourceforge/trebuchet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ >=dev-lang/tk-8.3.3:0=
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "/Nothing/d" \
+ -e "/LN/ s:../libexec:/usr/share:" \
+ Makefile || die
+}
+
+src_install() {
+ emake prefix="${D}/usr" \
+ ROOT="${D}/usr/share/${PN}" install
+
+ insinto /usr/share/${PN}
+ doins COPYING
+ dodoc changes.txt readme.txt trebtodo.txt
+}