summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-11-15 21:02:35 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-15 21:02:35 +0100
commit0cd6ea0f6f0d16ab338ac3c9250fb764541976e8 (patch)
tree2950e5f2f0f62354e6b3c07ea24274aef1045d90 /games-mud
parentgames-mud/tf: fix build, fix version number (diff)
downloadgentoo-0cd6ea0f6f0d16ab338ac3c9250fb764541976e8.tar.gz
gentoo-0cd6ea0f6f0d16ab338ac3c9250fb764541976e8.tar.bz2
gentoo-0cd6ea0f6f0d16ab338ac3c9250fb764541976e8.zip
games-mud/tf: drop old (or, rather, too new)
Closes: https://github.com/gentoo/gentoo/pull/17545 Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/tf/files/tf-50_beta8-stdarg.patch30
-rw-r--r--games-mud/tf/tf-50_beta8-r2.ebuild70
2 files changed, 0 insertions, 100 deletions
diff --git a/games-mud/tf/files/tf-50_beta8-stdarg.patch b/games-mud/tf/files/tf-50_beta8-stdarg.patch
deleted file mode 100644
index a34b70abe1fd..000000000000
--- a/games-mud/tf/files/tf-50_beta8-stdarg.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -U5 -r a/src/tfio.c b/src/tfio.c
---- a/src/tfio.c 2007-01-13 18:12:39.000000000 -0500
-+++ b/src/tfio.c 2007-02-02 16:50:12.000000000 -0500
-@@ -495,10 +495,11 @@
- const char *q, *sval;
- char *specptr, quote;
- const conString *Sval;
- int len, min, max, leftjust, stars;
- attr_t attrs = buf->attrs;
-+ va_list aq;
-
- if (!(flags & SP_APPEND) && buf->data) Stringtrunc(buf, 0);
- while (*fmt) {
- if (*fmt != '%' || *++fmt == '%') {
- for (q = fmt + 1; *q && *q != '%'; q++);
-@@ -520,11 +521,13 @@
- switch (*fmt) {
- case 'd': case 'i':
- case 'x': case 'X': case 'u': case 'o':
- case 'f': case 'e': case 'E': case 'g': case 'G':
- case 'p':
-- vsprintf(tempbuf, spec, ap);
-+ va_copy(aq, ap);
-+ vsprintf(tempbuf, spec, aq);
-+ va_end(aq);
- Stringcat(buf, tempbuf);
- /* eat the arguments used by vsprintf() */
- while (stars--) (void)va_arg(ap, int);
- switch (*fmt) {
- case 'd': case 'i':
diff --git a/games-mud/tf/tf-50_beta8-r2.ebuild b/games-mud/tf/tf-50_beta8-r2.ebuild
deleted file mode 100644
index 1009fb07dc03..000000000000
--- a/games-mud/tf/tf-50_beta8-r2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="${P/_beta/b}"
-
-DESCRIPTION="A small, flexible, screen-oriented MUD client (aka TinyFugue)"
-HOMEPAGE="http://tinyfugue.sourceforge.net/"
-SRC_URI="
- mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
- http://homepage.mac.com/mikeride/abelinc/scripts/allrootpatch.txt -> tf-allrootpatch.txt
- http://homepage.mac.com/mikeride/abelinc/scripts/allsrcpatch.txt -> tf-allsrcpatch.txt
- doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+atcp debug doc +gmcp ipv6 +option102 ssl"
-
-RDEPEND="
- ssl? ( dev-libs/openssl:0= )
- dev-libs/libpcre"
-DEPEND=${RDEPEND}
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${DISTDIR}"/tf-allrootpatch.txt
- "${DISTDIR}"/tf-allsrcpatch.txt
- "${FILESDIR}"/${P}-pcre.patch
- "${FILESDIR}"/${P}-stdarg.patch
-)
-
-src_configure() {
- STRIP=: econf \
- $(use_enable atcp) \
- $(use_enable gmcp) \
- $(use_enable option102) \
- $(use_enable ssl) \
- $(use_enable debug core) \
- $(use_enable ipv6 inet6) \
- --enable-manpage
-}
-
-src_install() {
- dobin src/tf
- newman src/tf.1.nroffman tf.1
-
- use doc && HTML_DOCS=( ../${MY_P}-help/{*.html,commands,topics} )
- einstalldocs
-
- insinto /usr/share/${PN}-lib
- # the application looks for this file here if /changes is called.
- # see comments on bug #23274
- doins CHANGES
- insopts -m0755
- doins -r tf-lib/.
-}
-
-pkg_postinst() {
- if use ipv6; then
- ewarn
- ewarn "You have merged TinyFugue with IPv6-support."
- ewarn "Support for IPv6 is still being experimental."
- ewarn "If you experience problems with connecting to hosts,"
- ewarn "try re-merging this package with USE="-ipv6""
- ewarn
- fi
-}