summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/bubble-chains
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/bubble-chains')
-rw-r--r--games-puzzle/bubble-chains/Manifest1
-rw-r--r--games-puzzle/bubble-chains/bubble-chains-0.1.1.ebuild49
-rw-r--r--games-puzzle/bubble-chains/metadata.xml5
3 files changed, 55 insertions, 0 deletions
diff --git a/games-puzzle/bubble-chains/Manifest b/games-puzzle/bubble-chains/Manifest
new file mode 100644
index 000000000000..656fef7cb128
--- /dev/null
+++ b/games-puzzle/bubble-chains/Manifest
@@ -0,0 +1 @@
+DIST chains-0.1.1-src.7z 3282431 SHA256 c1c487c51e8cba1640a49497debe5962f692e17df1272994c5dfaee9d6eb304f SHA512 2557974ccfa474329924684d859abae8555bdf7fc8e3264883ed0802255bd29ae486b8150b5ffd2d1b4176d0b8d98aec35f7717da4a6606a6c21026a41f1297c WHIRLPOOL bed7a7d1a64447715d47da432ee495fa5ae4d17ed99376182188398f6c846fa38c5666eac722fd60e7003d77660708809763f5f3466abefccee0b739e74bd69d
diff --git a/games-puzzle/bubble-chains/bubble-chains-0.1.1.ebuild b/games-puzzle/bubble-chains/bubble-chains-0.1.1.ebuild
new file mode 100644
index 000000000000..310d6506b5d2
--- /dev/null
+++ b/games-puzzle/bubble-chains/bubble-chains-0.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic qt4-r2 games
+
+MY_P=${P/bubble-}-src
+
+DESCRIPTION="Arcade-puzzle game"
+HOMEPAGE="http://bubble-chains.sintegrial.com/"
+SRC_URI="http://${PN}.sintegrial.com/files/${MY_P}.7z"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXrandr
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/p7zip"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ append-cxxflags $(pkg-config sdl --cflags)
+ sed -i \
+ -e "s:/usr/local/bin:${GAMES_BINDIR}:g" \
+ -e "s:/usr/local/games:${GAMES_DATADIR}:g" \
+ -e "s:LIBS += -lSDLmain:LIBS += -lSDL -lX11:" \
+ Game.pro main.cpp || die
+}
+
+src_configure() {
+ eqmake4 Game.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ dodoc README
+ newicon images/img64_base.png ${PN}.png
+ make_desktop_entry chains "Bubble Chains"
+ prepgamesdirs
+}
diff --git a/games-puzzle/bubble-chains/metadata.xml b/games-puzzle/bubble-chains/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/bubble-chains/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>