summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch')
-rw-r--r--games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch b/games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch
new file mode 100644
index 000000000000..abee05096288
--- /dev/null
+++ b/games-puzzle/galaxis/files/galaxis-1.8-gentoo.patch
@@ -0,0 +1,60 @@
+diff -ru galaxis-1.8.orig/Makefile galaxis-1.8/Makefile
+--- galaxis-1.8.orig/Makefile 2010-10-19 09:48:58.000000000 -0400
++++ galaxis-1.8/Makefile 2010-10-20 04:04:49.246650551 -0400
+@@ -3,9 +3,8 @@
+ VERS=$(shell sed <galaxis.spec -n -e '/Version: \(.*\)/s//\1/p')
+
+ # Flags for use with the Linux ncurses package (recommended)
+-CFLAGS = -g -DNDEBUG # -I/usr/local/include -L/usr/local/lib
++CFLAGS += -DNDEBUG # -I/usr/local/include -L/usr/local/lib
+ TERMLIB = -lncurses
+-CC = gcc
+
+ # Flags for use with stock curses
+ #CFLAGS = -DNDEBUG
+@@ -13,7 +12,7 @@
+ #CC = gcc
+
+ galaxis: galaxis.c
+- $(CC) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o galaxis galaxis.c $(TERMLIB)
+
+ galaxis.6: galaxis.xml
+ xmlto man galaxis.xml
+diff -ru galaxis-1.8.orig/galaxis.c galaxis-1.8/galaxis.c
+--- galaxis-1.8.orig/galaxis.c 2010-10-13 06:13:31.000000000 -0400
++++ galaxis-1.8/galaxis.c 2010-10-20 04:05:30.036888771 -0400
+@@ -8,6 +8,8 @@
+ #define _POSIX_SOURCE
+
+ #include <stdio.h>
++#include <unistd.h>
++#include <time.h>
+ #include <termios.h>
+ #include <curses.h>
+ #include <signal.h>
+@@ -176,6 +177,7 @@
+ (void) refresh();
+ }
+
++#if 0
+ static void error(char *s)
+ {
+ (void) move(PROMPTLINE + 2, 0);
+@@ -186,6 +188,7 @@
+ (void) beep();
+ }
+ }
++#endif
+
+ static int rnd(int n)
+ {
+@@ -644,7 +647,7 @@
+ }
+ }
+
+-main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {