summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/hoh-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/hoh-bin')
-rw-r--r--games-puzzle/hoh-bin/Manifest1
-rw-r--r--games-puzzle/hoh-bin/hoh-bin-1.01.ebuild47
-rw-r--r--games-puzzle/hoh-bin/metadata.xml5
3 files changed, 53 insertions, 0 deletions
diff --git a/games-puzzle/hoh-bin/Manifest b/games-puzzle/hoh-bin/Manifest
new file mode 100644
index 000000000000..cce1a25c0230
--- /dev/null
+++ b/games-puzzle/hoh-bin/Manifest
@@ -0,0 +1 @@
+DIST hohlin-101.tar.bz2 14808528 SHA256 72e0e14f28a1245b34455d6c9c1b4715d297e165f6cdf3aa8fc525429b9839ee SHA512 38f5815d9b2356c5d566d8b5b4730e1ed24192dfb5c3fcae9096b4a2c6110de60245b13da6bffc359032165d7fc0681a6adfa3503005c9281807c4734d519c0b WHIRLPOOL 32e0d466c214d9f0d3b97fb1ec8a66bc0d6b499b143743009d7280e1384492539d14e3f7f7d8e1c029bbdd7cb5e515d63368d2c1ad0b3fe79d9e727a2160c32a
diff --git a/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild b/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
new file mode 100644
index 000000000000..63232abb54f1
--- /dev/null
+++ b/games-puzzle/hoh-bin/hoh-bin-1.01.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="PC remake of the spectrum game, Head Over Heels"
+HOMEPAGE="http://retrospec.sgn.net/games/hoh/"
+SRC_URI="http://retrospec.sgn.net/download.php?id=63\&path=games/hoh/bin/hohlin-${PV/./}.tar.bz2"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="x11-libs/libX11[abi_x86_32(-)]"
+
+S=${WORKDIR}/hoh-install-${PV}
+
+# bug #448420
+QA_PREBUILT="
+/opt/HoH/data/runtime/libstdc++-libc6.2-2.so.3
+/opt/HoH/data/HoH
+"
+
+src_compile() {
+ cat > "${T}/hoh" <<-EOF
+ #!/bin/bash
+ export LD_LIBRARY_PATH="${GAMES_PREFIX_OPT}/HoH/data/runtime"
+ cd "${GAMES_PREFIX_OPT}/HoH/data"
+ exec ./HoH \$@
+EOF
+}
+
+src_install() {
+ local DATADIR="${GAMES_PREFIX_OPT}/HoH/data"
+ local DOCDIR="${GAMES_PREFIX_OPT}/HoH/docs"
+
+ dogamesbin "${T}/hoh"
+ dodir "${DATADIR}" "${DOCDIR}"
+ cp -pPRf data/* "${D}/${DATADIR}/" || die
+ cp -pPRf docs/* "${D}/${DOCDIR}/" || die
+ make_desktop_entry hoh "Head Over Heels"
+ prepgamesdirs
+}
diff --git a/games-puzzle/hoh-bin/metadata.xml b/games-puzzle/hoh-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/hoh-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>