summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-12-25 20:28:35 +0100
committerPacho Ramos <pacho@gentoo.org>2019-12-25 20:30:23 +0100
commit07813a42e9eb824a45d6997f578ef1f9812d15c6 (patch)
treec84aee9402a56b492feab37c7181523cac127295 /games-puzzle/monsterz
parentgames-puzzle/angrydd: Drop old (diff)
downloadgentoo-07813a42e9eb824a45d6997f578ef1f9812d15c6.tar.gz
gentoo-07813a42e9eb824a45d6997f578ef1f9812d15c6.tar.bz2
gentoo-07813a42e9eb824a45d6997f578ef1f9812d15c6.zip
games-puzzle/monsterz: Fixes from Debian, python3 support
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/Manifest1
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-gentoo-r1.patch11
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1_p11.ebuild57
3 files changed, 69 insertions, 0 deletions
diff --git a/games-puzzle/monsterz/Manifest b/games-puzzle/monsterz/Manifest
index 874f1fe627d1..dc3d0158282f 100644
--- a/games-puzzle/monsterz/Manifest
+++ b/games-puzzle/monsterz/Manifest
@@ -1 +1,2 @@
DIST monsterz-0.7.1.tar.gz 1879537 BLAKE2B e1ad9f17a64bcbb07005eb61d951dbf756997a6e6bd76c48d88bb634c9b3167c9fd41ef32032925b219153eb607dc238af76b44c3ef6c47aab753d59c61958e1 SHA512 62de125251a74e7ff237c90ad88e10a4953b8841251dfec45cc6b77f416677ef6d68cf4308c3190f65896b5bb1312934abd5e438f0341f08c02884585f0e4787
+DIST monsterz_0.7.1-11.debian.tar.xz 13688 BLAKE2B 2274b6d18b2f03200e09468243bae7ede94b81bd7595f65a73fd33bc9ccc7302fbea3a4876b5bbf6cf98735652742b1cf76b3c288fc6c005f9566c04b4a4f277 SHA512 c172355667db29de949de07745469552d62dc226120f38ff76a288b14018424338f27b6a562de215b7194b8b09c6346d29e9088c8a0edb0fe915f915b8577a4b
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo-r1.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo-r1.patch
new file mode 100644
index 000000000000..bd8a825c3c46
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo-r1.patch
@@ -0,0 +1,11 @@
+--- a/monsterz.py.old 2019-12-25 20:25:16.680365172 +0100
++++ b/monsterz.py 2019-12-25 20:25:50.606666122 +0100
+@@ -1991,7 +1991,7 @@
+ global system, data, settings, fonter, monsterz
+ override = {}
+ scorefile = None
+- sharedir = dirname(argv[0])
++ sharedir = "GENTOO_DATADIR"
+ outfd = None
+ try:
+ long = ['help', 'version', 'music', 'sound', 'fullscreen',
diff --git a/games-puzzle/monsterz/monsterz-0.7.1_p11.ebuild b/games-puzzle/monsterz/monsterz-0.7.1_p11.ebuild
new file mode 100644
index 000000000000..74cbff40172a
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1_p11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit desktop python-r1
+
+DESCRIPTION="A little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="
+ http://sam.zoy.org/projects/monsterz/${P/_p*}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+"
+
+LICENSE="GPL-1+ LGPL-2+ WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/_p*}"
+
+src_prepare() {
+ default
+
+ # Debian fixes
+ for p in $(<"${WORKDIR}"/debian/patches/series) ; do
+ eapply -p1 "${WORKDIR}/debian/patches/${p}"
+ done
+
+ eapply "${FILESDIR}"/${PN}-0.7.1-gentoo-r1.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:/usr/share/${PN}:" \
+ monsterz.py || die "sed failed"
+
+ rm Makefile || die
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r graphics sound
+ newbin monsterz.py ${PN}
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ einstalldocs
+ python_replicate_script "${ED}"/usr/bin/monsterz
+}