summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-12-25 20:30:12 +0100
committerPacho Ramos <pacho@gentoo.org>2019-12-25 20:30:24 +0100
commitbdd1fec26fcad4ca842c4ce12a8daf815e5f37ef (patch)
treec857c6d4129740428914cff6fae7c9848a36b756 /games-puzzle/monsterz
parentgames-puzzle/monsterz: Make repoman happy (diff)
downloadgentoo-bdd1fec26fcad4ca842c4ce12a8daf815e5f37ef.tar.gz
gentoo-bdd1fec26fcad4ca842c4ce12a8daf815e5f37ef.tar.bz2
gentoo-bdd1fec26fcad4ca842c4ce12a8daf815e5f37ef.zip
games-puzzle/monsterz: Drop old
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch26
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch32
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch20
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild47
4 files changed, 0 insertions, 125 deletions
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch
deleted file mode 100644
index 64d6527768f8..000000000000
--- a/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: monsterz-0.7.1/monsterz.py
-===================================================================
---- monsterz-0.7.1.orig/monsterz.py 2008-05-09 16:35:25.000000000 +0000
-+++ monsterz-0.7.1/monsterz.py 2008-05-09 16:35:33.000000000 +0000
-@@ -108,7 +108,9 @@
- M = int(max(r, g, b))
- m = int(min(r, g, b))
- val = (2 * M + r + g + b) / 5
-- p[:] = (val + r) / 2, (val + g) / 2, (val + b) / 2
-+ p[0] = (val + r) / 2
-+ p[1] = (val + g) / 2
-+ p[2] = (val + b) / 2
- if alpha[y][x] >= 250:
- alpha[y][x] = 255 - (M - m) * 3 / 4
- del pixels
-@@ -129,7 +131,9 @@
- r, g, b = p
- M = int(max(r, g, b))
- m = int(min(r, g, b))
-- p[:] = (m + r) / 2, (m + g) / 2, (m + b) / 2
-+ p[0] = (m + r) / 2
-+ p[1] = (m + g) / 2
-+ p[2] = (m + b) / 2
- if alpha[y][x] >= 250:
- alpha[y][x] = 255 - M * 2 / 3
- del pixels
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
deleted file mode 100644
index d0847d6c2c10..000000000000
--- a/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/monsterz.py
-+++ b/monsterz.py
-@@ -829,10 +829,10 @@
- pass
- else:
- for x in range(4):
-- for y, p in enumerate(alpha[x]):
-- alpha[x][y] = p * x / 4
-- for y, p in enumerate(alpha[406 - x - 1]):
-- alpha[406 - x - 1][y] = p * x / 4
-+ for y in range(len(alpha[x])):
-+ alpha[x][y] = alpha[x][y] * x / 4
-+ for y in range(len(alpha[406 - x - 1])):
-+ alpha[406 - x - 1][y] = alpha[406 - x - 1][y] * x / 4
- for col in alpha:
- l = len(col)
- for y in range(4):
-@@ -1287,10 +1287,10 @@
- pass
- else:
- for x in range(10):
-- for y, p in enumerate(alpha[x]):
-- alpha[x][y] = p * x / 12
-- for y, p in enumerate(alpha[406 - x - 1]):
-- alpha[406 - x - 1][y] = p * x / 12
-+ for y in range(len(alpha[x])):
-+ alpha[x][y] = alpha[x][y] * x / 12
-+ for y in range(len(alpha[406 - x - 1])):
-+ alpha[406 - x - 1][y] = alpha[406 - x - 1][y] * x / 12
- del alpha
- scroll.unlock()
- system.blit(scroll, (13, 437))
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
deleted file mode 100644
index 6920e0e36971..000000000000
--- a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/monsterz.py.orig 2006-05-12 18:55:51.000000000 -0400
-+++ b/monsterz.py 2006-05-12 18:57:44.000000000 -0400
-@@ -1907,7 +1906,7 @@
- print ' (C) Mike Kershaw <dragorn@kismetwireless.net>'
-
- print 'This program is free software; you can redistribute it and/or modify it under'
-- print 'the terms of the Do What The Fuck You Want To Public License, Version 2, as'
-+ print 'the terms of the WTFPL, Version 2, as'
- print 'published by Sam Hocevar. See http://sam.zoy.org/wtfpl/ for more details.'
- print 'The sound effects are released under their own licences: applause.wav and'
- print 'pop.wav are covered by the LGPL, the others are covered by the GPL.'
-@@ -1932,7 +1931,7 @@
- global system, data, settings, fonter, monsterz
- override = {}
- scorefile = None
-- sharedir = dirname(argv[0])
-+ sharedir = "GENTOO_DATADIR"
- outfd = None
- try:
- long = ['help', 'version', 'music', 'sound', 'fullscreen',
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild
deleted file mode 100644
index 4cff31b75f8c..000000000000
--- a/games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit desktop python-r1
-
-DESCRIPTION="A little puzzle game, similar to the famous Bejeweled or Zookeeper"
-HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
-SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
-
-LICENSE="GPL-1+ LGPL-2+ WTFPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
-
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/pygame[${PYTHON_USEDEP}]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer[mod]
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
- eapply \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-64bit.patch \
- "${FILESDIR}"/${P}-blit.patch
- sed -i \
- -e "s:GENTOO_DATADIR:/usr/share/${PN}:" \
- monsterz.py || die "sed failed"
- rm Makefile || die
-}
-
-src_install() {
- insinto /usr/share/${PN}
- doins -r graphics sound
- newbin monsterz.py ${PN}
- newicon graphics/icon.png ${PN}.png
- make_desktop_entry ${PN} Monsterz
- einstalldocs
- python_replicate_script "${ED%/}"/usr/bin/monsterz
-}