summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/neverball/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/neverball/files')
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-libpng.patch21
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-lm.patch28
-rw-r--r--games-puzzle/neverball/files/neverball-1.5.4-underlink.patch11
3 files changed, 60 insertions, 0 deletions
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch b/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch
new file mode 100644
index 000000000000..d7b224673186
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-libpng.patch
@@ -0,0 +1,21 @@
+Index: neverball-1.5.4/share/base_image.c
+===================================================================
+--- neverball-1.5.4.orig/share/base_image.c
++++ neverball-1.5.4/share/base_image.c
+@@ -15,6 +15,7 @@
+ #include <png.h>
+ #include <jpeglib.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <assert.h>
+
+ #include "glext.h"
+@@ -94,7 +95,7 @@ static void *image_load_png(const char *
+ default: longjmp(png_jmpbuf(readp), -1);
+ }
+
+- if (!(bytep = png_malloc(readp, h * png_sizeof(png_bytep))))
++ if (!(bytep = png_malloc(readp, h * sizeof(png_bytep))))
+ longjmp(png_jmpbuf(readp), -1);
+
+ /* Allocate the final pixel buffer and read pixels there. */
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-lm.patch b/games-puzzle/neverball/files/neverball-1.5.4-lm.patch
new file mode 100644
index 000000000000..4245e28fe2f2
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-lm.patch
@@ -0,0 +1,28 @@
+Fix link faiure against -lm
+
+x86_64-pc-linux-gnu-gcc -Wall -ansi -pedantic -march=core2 -O2 -pipe -ggdb -o neverball-mapc share/vec3.o share/base_image.o share/solid.o share/binary.o share/base_config.o share/common.o share/fs.o share/fs_png.o share/fs_jpg.o share/dir.o share/array.o share/mapc.o -Wl,-O1 -Wl,--as-needed -ljpeg -lpng15 -lphysfs
+/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld: share/mapc.o: undefined reference to symbol 'acosf@@GLIBC_2.2.5'
+/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld: note: 'acosf@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
+
+Gentoo-bug: http://bugs.gentoo.org/464014
+diff --git a/Makefile b/Makefile
+index 62a87e9..1816707 100644
+--- a/Makefile
++++ b/Makefile
+@@ -132,6 +132,7 @@ ifdef DARWIN
+ endif
+
+ BASE_LIBS := -ljpeg $(PNG_LIBS) $(FS_LIBS)
++MAPC_LIBS := -lm # only acosf user
+
+ ifdef DARWIN
+ BASE_LIBS += -L/opt/local/lib
+@@ -318,7 +319,7 @@ $(PUTT_TARG) : $(PUTT_OBJS)
+ $(CC) $(ALL_CFLAGS) -o $(PUTT_TARG) $(PUTT_OBJS) $(LDFLAGS) $(ALL_LIBS)
+
+ $(MAPC_TARG) : $(MAPC_OBJS)
+- $(CC) $(ALL_CFLAGS) -o $(MAPC_TARG) $(MAPC_OBJS) $(LDFLAGS) $(BASE_LIBS)
++ $(CC) $(ALL_CFLAGS) -o $(MAPC_TARG) $(MAPC_OBJS) $(LDFLAGS) $(MAPC_LIBS) $(BASE_LIBS)
+
+ # Work around some extremely helpful sdl-config scripts.
+
diff --git a/games-puzzle/neverball/files/neverball-1.5.4-underlink.patch b/games-puzzle/neverball/files/neverball-1.5.4-underlink.patch
new file mode 100644
index 000000000000..c6f27cc2bf8a
--- /dev/null
+++ b/games-puzzle/neverball/files/neverball-1.5.4-underlink.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2011-06-22 06:30:52.441788160 +0200
++++ Makefile 2011-06-22 06:31:59.754087534 +0200
+@@ -138,7 +138,7 @@
+ endif
+
+ ALL_LIBS := $(SDL_LIBS) $(BASE_LIBS) $(TILT_LIBS) $(INTL_LIBS) -lSDL_ttf \
+- -lvorbisfile $(OGL_LIBS)
++ -lvorbisfile $(OGL_LIBS) -lX11
+
+ #------------------------------------------------------------------------------
+