summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/ngstar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/ngstar')
-rw-r--r--games-puzzle/ngstar/Manifest1
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-gcc43.patch10
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch11
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-gentoo-path.patch14
-rw-r--r--games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch32
-rw-r--r--games-puzzle/ngstar/metadata.xml14
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild45
7 files changed, 127 insertions, 0 deletions
diff --git a/games-puzzle/ngstar/Manifest b/games-puzzle/ngstar/Manifest
new file mode 100644
index 000000000000..a722d4c617cb
--- /dev/null
+++ b/games-puzzle/ngstar/Manifest
@@ -0,0 +1 @@
+DIST ngstar-2.1.8-src.tar.bz2 45851 SHA256 c8a2cf84d2a4bb40280d4ce307ceaed8f97d2183f79f7a82b38b78aaedb73fb3 SHA512 c96031148720b5dcc004a5de68137bbbdd5af9c6f0b33ff8bcee3180cbf4732a4d6a92737ef99754d512bb61454bc0a17487efba4cdb00339d23e38edfe3cb28 WHIRLPOOL 05b6492a324e49c210174864b73194cef1ef3deb405d04d1c9352ae3cb3bb539e3c2b5c4d11f09f2ea32ffe37a542aaf2438185f6df1330af88de0b122d6e5aa
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-gcc43.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-gcc43.patch
new file mode 100644
index 000000000000..72c0f70007a4
--- /dev/null
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-gcc43.patch
@@ -0,0 +1,10 @@
+--- libngstar2/Configuration.hh
++++ libngstar2/Configuration.hh
+@@ -26,6 +26,7 @@
+ #include <fstream>
+ #include <iostream>
+ #include <string>
++#include <cstdlib>
+
+ #include <getopt.h>
+ #include <sys/stat.h>
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch
new file mode 100644
index 000000000000..2ddf0f53793d
--- /dev/null
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-gcc47.patch
@@ -0,0 +1,11 @@
+--- src/Ncurses_UI.cc.old 2012-07-21 22:25:16.421521521 +0200
++++ src/Ncurses_UI.cc 2012-07-21 22:26:01.008390914 +0200
+@@ -23,6 +23,8 @@
+ /* includes */
+ #include "Ncurses_UI.hh"
+
++#include <unistd.h>
++
+ using namespace ngstar2;
+
+ Ncurses_UI::Ncurses_UI( NGStar2 *engine, Configuration* config, Scores *scores )
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-gentoo-path.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-gentoo-path.patch
new file mode 100644
index 000000000000..84fa6de7e024
--- /dev/null
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-gentoo-path.patch
@@ -0,0 +1,14 @@
+--- configure.old 2006-04-19 22:00:42.000000000 +0200
++++ configure 2006-04-19 22:02:38.000000000 +0200
+@@ -193,8 +193,8 @@
+ MINOR = $VMINOR
+ REVISION = $VREVISION
+
+-LEVELSETS_DIR = \$(PREFIX)/share/\$(NAME)/levelsets
+-THEMES_DIR = \$(PREFIX)/share/\$(NAME)/themes
+-BIN_DIR = \$(PREFIX)/bin
++LEVELSETS_DIR = \$(PREFIX)@GENTOO_DATA@/\$(NAME)/levelsets
++THEMES_DIR = \$(PREFIX)@GENTOO_DATA@/\$(NAME)/themes
++BIN_DIR = \$(PREFIX)@GENTOO_BIN@
+ DOC_DIR = \$(PREFIX)/doc/\$(NAME)-\$(MAJOR).\$(MINOR).\$(REVISION)
+ LIB_DIR = \$(PREFIX)/lib
diff --git a/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch b/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
new file mode 100644
index 000000000000..17e0ed9f7188
--- /dev/null
+++ b/games-puzzle/ngstar/files/ngstar-2.1.8-ldflags.patch
@@ -0,0 +1,32 @@
+diff -ru ngstar-2.1.8.orig/src/Makefile ngstar-2.1.8/src/Makefile
+--- ngstar-2.1.8.orig/src/Makefile 2005-11-09 08:11:22.000000000 -0500
++++ ngstar-2.1.8/src/Makefile 2014-11-18 23:58:45.565366080 -0500
+@@ -33,8 +33,8 @@
+ endif
+ endif
+ ifdef USE_NCURSES
+- CC_LIBS += -lncurses -lgpm
+- CC_LIBS_STATIC += -lncurses -lgpm
++ CC_LIBS += $(shell pkg-config ncurses --libs) -lgpm
++ CC_LIBS_STATIC += $(shell pkg-config ncurses --libs) -lgpm
+
+ NCURSES_UI_OBJ = Ncurses_UI.o
+
+@@ -56,8 +56,7 @@
+
+ $(BIN) : $(SOURCE) $(BIN_DEPS)
+ echo "Compiling $(BIN)"
+- $(CXX) $< $(BIN_DEPS) -o $@ $(CC_LIBS) $(CC_INCLUDES) $(CPPFLAGS)
+- strip -s $@
++ $(CXX) ${LDFLAGS} $< $(BIN_DEPS) -o $@ $(CC_LIBS) $(CC_INCLUDES) $(CPPFLAGS)
+ ifdef USE_FLTK2
+ -ln -s `basename $(BIN)` $(BIN_FLTK2)
+ endif
+@@ -68,7 +67,6 @@
+ $(BIN_STATIC) : $(SOURCE) $(BIN_DEPS)
+ echo "Compiling $(BIN)"
+ $(CXX) -static $< $(BIN_DEPS) -o $@ $(CC_LIBS_STATIC) $(CC_INCLUDES) $(CPPFLAGS)
+- strip -s $@
+ ifdef USE_FLTK2
+ -ln -s `basename $(BIN_STATIC)` $(BIN_STATIC_FLTK2)
+ endif
diff --git a/games-puzzle/ngstar/metadata.xml b/games-puzzle/ngstar/metadata.xml
new file mode 100644
index 000000000000..6dba63b5876e
--- /dev/null
+++ b/games-puzzle/ngstar/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription lang="en">
+NGStar is a clone of a HP48 game called dstar.
+The goal is to catch all gifts in the level to get access to the next one.
+Use the ball to catch them, use the cube to stop the ball. The ball only move
+to the next obstacle (wall or cube).
+</longdescription>
+ <upstream>
+ <remote-id type="freshmeat">ngstar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
new file mode 100644
index 000000000000..2a98419b33e6
--- /dev/null
+++ b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="NGStar is a clone of a HP48 game called dstar"
+HOMEPAGE="http://freshmeat.net/projects/ngstar"
+SRC_URI="mirror://gentoo//${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/gpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo-path.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e "s:@GENTOO_DATA@:${GAMES_DATADIR}:" \
+ -e "s:@GENTOO_BIN@:${GAMES_BINDIR}:" \
+ -e "/^CPPFLAGS/s:+=:+= ${CXXFLAGS}:" \
+ -e "/SILENT/d" \
+ configure || die
+}
+
+src_configure() {
+ ./configure \
+ --prefix "" \
+ --without-fltk2 || die
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}