summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-08 15:08:50 +0000
committerSam James <sam@gentoo.org>2021-01-08 15:09:34 +0000
commit4720158264396a3ffbe291018c5a8d81fa2fc31b (patch)
treeb95bd4b75e10faf37fff779c7f200aea2ba1e185 /games-puzzle/nudoku/nudoku-2.1.0.ebuild
parentx11-misc/obmenu-generator: 0.89 stable (diff)
downloadgentoo-4720158264396a3ffbe291018c5a8d81fa2fc31b.tar.gz
gentoo-4720158264396a3ffbe291018c5a8d81fa2fc31b.tar.bz2
gentoo-4720158264396a3ffbe291018c5a8d81fa2fc31b.zip
games-puzzle/nudoku: bump to 2.1.0
Closes: https://bugs.gentoo.org/764470 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle/nudoku/nudoku-2.1.0.ebuild')
-rw-r--r--games-puzzle/nudoku/nudoku-2.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-puzzle/nudoku/nudoku-2.1.0.ebuild b/games-puzzle/nudoku/nudoku-2.1.0.ebuild
new file mode 100644
index 000000000000..9c8b8766b692
--- /dev/null
+++ b/games-puzzle/nudoku/nudoku-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="ncurses based sudoku game"
+HOMEPAGE="https://jubalh.github.io/nudoku"
+SRC_URI="https://github.com/jubalh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cairo"
+
+DEPEND="
+ cairo? ( x11-libs/cairo )
+ sys-libs/ncurses:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.1.0-ncurses-link.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable cairo)
+}