summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/penguzzle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/penguzzle')
-rw-r--r--games-puzzle/penguzzle/Manifest1
-rw-r--r--games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch10
-rw-r--r--games-puzzle/penguzzle/metadata.xml5
-rw-r--r--games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild46
4 files changed, 62 insertions, 0 deletions
diff --git a/games-puzzle/penguzzle/Manifest b/games-puzzle/penguzzle/Manifest
new file mode 100644
index 000000000000..54ad252dcae5
--- /dev/null
+++ b/games-puzzle/penguzzle/Manifest
@@ -0,0 +1 @@
+DIST penguzzle.zip 21542 SHA256 f3c2a4bc94fcd3d00cd8be9bf748bd3b0aa6d4251e64620fe92524e65fb951cd SHA512 fc6c57ac851df7fac7d91f90ec53fa543470e9721589966023028743951090994c372ff4538092c29aee12afc28809ad6e20a6b78ae9759bad2b41fed330b743 WHIRLPOOL 5c5e4b5a0c3f8640ee196eef73a84d8b7d472458e78f1bed3b09427cbd82cf3d3792b2b11219ff8e55f57638147f1e36ff2fcb939565d24b278ac711080d1a21
diff --git a/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch b/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
new file mode 100644
index 000000000000..d8c078de6a91
--- /dev/null
+++ b/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
@@ -0,0 +1,10 @@
+--- bin/penguzzle
++++ bin/penguzzle
+@@ -1,4 +1,6 @@
+-#!/usr/bin/wishx
++#!/usr/bin/wish
++package require Tk
++package require Tclx
+
+ source ~/puzz/lib/init
+
diff --git a/games-puzzle/penguzzle/metadata.xml b/games-puzzle/penguzzle/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/penguzzle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
new file mode 100644
index 000000000000..58fa75f8dd4c
--- /dev/null
+++ b/games-puzzle/penguzzle/penguzzle-1.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
+HOMEPAGE="http://www.naskita.com/linux/penguzzle/penguzzle.shtml"
+SRC_URI="http://www.naskita.com/linux/${PN}/${PN}.zip"
+
+LICENSE="penguzzle"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/tk
+ dev-tcltk/tclx"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}${PV}
+
+src_prepare() {
+ sed -i \
+ -e "s:~/puzz/images:${GAMES_DATADIR}/${PN}:" \
+ lib/init \
+ || die "sed init failed"
+ sed -i \
+ -e "s:~/puzz/lib:$(games_get_libdir)/${PN}:" \
+ bin/${PN} \
+ || die "sed ${PN} failed"
+
+ epatch "${FILESDIR}"/${P}-tclx.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins images/img0.gif
+
+ insinto "$(games_get_libdir)"/${PN}
+ doins lib/init
+
+ dogamesbin bin/${PN}
+
+ dodoc README
+ prepgamesdirs
+}