summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 15:42:42 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:33:51 +0200
commit86298ae4e7325d9b7c68734596f3aeb68758bef7 (patch)
treebfeb277a1c37bec53dd110e96bcaf9be8078a1c5 /games-puzzle/penguzzle
parentgames-puzzle/pauker: Drop old (diff)
downloadgentoo-86298ae4e7325d9b7c68734596f3aeb68758bef7.tar.gz
gentoo-86298ae4e7325d9b7c68734596f3aeb68758bef7.tar.bz2
gentoo-86298ae4e7325d9b7c68734596f3aeb68758bef7.zip
games-puzzle/penguzzle: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/penguzzle')
-rw-r--r--games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch4
-rw-r--r--games-puzzle/penguzzle/penguzzle-1.0-r2.ebuild51
2 files changed, 53 insertions, 2 deletions
diff --git a/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch b/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
index d8c078de6a91..0f2ca8b8b23d 100644
--- a/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
+++ b/games-puzzle/penguzzle/files/penguzzle-1.0-tclx.patch
@@ -1,5 +1,5 @@
---- bin/penguzzle
-+++ bin/penguzzle
+--- a/bin/penguzzle
++++ b/bin/penguzzle
@@ -1,4 +1,6 @@
-#!/usr/bin/wishx
+#!/usr/bin/wish
diff --git a/games-puzzle/penguzzle/penguzzle-1.0-r2.ebuild b/games-puzzle/penguzzle/penguzzle-1.0-r2.ebuild
new file mode 100644
index 000000000000..54cc98723ec2
--- /dev/null
+++ b/games-puzzle/penguzzle/penguzzle-1.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Tcl/Tk variant of the well-known 15-puzzle game"
+HOMEPAGE="http://www.naskita.com/linux/penguzzle/penguzzle.shtml"
+SRC_URI="http://www.naskita.com/linux/${PN}/${PN}.zip"
+
+LICENSE="penguzzle"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/tk:0=
+ dev-tcltk/tclx
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:~/puzz/images:/usr/share/${PN}:" \
+ lib/init \
+ || die "sed init failed"
+ sed -i \
+ -e "s:~/puzz/lib:/usr/$(get_libdir)/${PN}:" \
+ bin/${PN} \
+ || die "sed ${PN} failed"
+
+ eapply "${FILESDIR}"/${P}-tclx.patch
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins images/img0.gif
+
+ insinto /usr/"$(get_libdir)"/${PN}
+ doins lib/init
+
+ dobin bin/${PN}
+
+ newicon images/img0.gif ${PN}.gif
+ make_desktop_entry ${PN} "Penguzzle" /usr/share/pixmaps/${PN}.gif
+
+ einstalldocs
+}