summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/pingus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/pingus')
-rw-r--r--games-puzzle/pingus/Manifest1
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch22
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch10
-rw-r--r--games-puzzle/pingus/metadata.xml21
-rw-r--r--games-puzzle/pingus/pingus-0.7.6.ebuild53
5 files changed, 107 insertions, 0 deletions
diff --git a/games-puzzle/pingus/Manifest b/games-puzzle/pingus/Manifest
new file mode 100644
index 000000000000..01fa8384f52f
--- /dev/null
+++ b/games-puzzle/pingus/Manifest
@@ -0,0 +1 @@
+DIST pingus-0.7.6.tar.bz2 12622268 SHA256 759c1253075d1e72691bc1e770b24cdd51917041fd1857c1daf85b65a6686460 SHA512 6c8c2ace1a9229b4e3b506aee76aa94c0dd906a64fa2c817902c2cd3854df390cf675c8c6ddd3ba1926a467348b2103818bd44bc095378cc7bf3f2ff7af27188 WHIRLPOOL 2c4bafef86c40fec3fcfc9ff4b298e72919c8309d475aa4aeb4d368927ac611801f416375108091d9f40bdb2703633765125f6f7ea361186f637e2d5234e53e2
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
new file mode 100644
index 000000000000..b1397da31f68
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-gcc47.patch
@@ -0,0 +1,22 @@
+--- src/pingus/pingus_main.cpp.orig 2012-07-08 14:02:40.343767438 +0200
++++ src/pingus/pingus_main.cpp 2012-07-08 14:02:54.062768168 +0200
+@@ -465,7 +465,7 @@
+ void
+ PingusMain::print_greeting_message()
+ {
+- std::string greeting = "Welcome to Pingus "VERSION;
++ std::string greeting = "Welcome to Pingus " VERSION;
+ greeting += "!";
+ std::cout << greeting << std::endl;
+ for (unsigned int i = 0; i < greeting.length(); ++i)
+--- src/pingus/screens/pingus_menu.cpp.orig 2012-07-08 14:03:05.549768782 +0200
++++ src/pingus/screens/pingus_menu.cpp 2012-07-08 14:03:17.015769393 +0200
+@@ -153,7 +153,7 @@
+ gc.get_height()/2 - 280));
+
+ gc.print_left(Fonts::pingus_small, Vector2i(gc.get_width()/2 - 400 + 25, gc.get_height()-140),
+- "Pingus "VERSION" - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
++ "Pingus " VERSION " - Copyright (C) 1998-2011 Ingo Ruhnke <grumbel@gmail.com>\n"
+ "See the file AUTHORS for a complete list of contributors.\n"
+ "Pingus comes with ABSOLUTELY NO WARRANTY. This is free software, and you are\n"
+ "welcome to redistribute it under certain conditions; see the file COPYING for details.\n");
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
new file mode 100644
index 000000000000..e474ef7376e5
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-noopengl.patch
@@ -0,0 +1,10 @@
+--- src/engine/display/display.cpp.orig 2012-06-30 00:30:13.043995049 -0400
++++ src/engine/display/display.cpp 2012-06-30 00:30:28.194501544 -0400
+@@ -28,6 +28,7 @@
+ #include "engine/display/delta/delta_framebuffer.hpp"
+ #include "engine/display/null_framebuffer.hpp"
+ #include "util/log.hpp"
++#include "util/raise_exception.hpp"
+
+ std::unique_ptr<Framebuffer> Display::s_framebuffer;
+
diff --git a/games-puzzle/pingus/metadata.xml b/games-puzzle/pingus/metadata.xml
new file mode 100644
index 000000000000..e5220f2a49c6
--- /dev/null
+++ b/games-puzzle/pingus/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <longdescription>Pingus is a free Lemmings clone for GNU/Linux and Windows covered under the GNU GPL. Pingus
+uses ClanLib and libxml and might also be usable on some other OSs like FreeBSD, but hasn't
+been tested there. Pingus is mainly developed under GNU/Linux, that's why the Windows port
+is sometimes a bit behind.
+If you don't know Lemmingstm, here comes a short introduction. Its a puzzle game developed
+in 1991 by DMA Design. The player takes command in the game of a bunch of small animals and
+has to guide them around in levels. Since the animals walk on their own, the player can only
+influence them by giving them commands, like build a bridge, dig a hole or redirect all
+animals in the other direction. The goal of each level is to reach the exit, for fix
+multiple combination of commands are necessary. The game is presented in a 2D site view.</longdescription>
+ <upstream>
+ <remote-id type="google-code">pingus</remote-id>
+ </upstream>
+ <use>
+ <flag name="music">Enable playing of background music</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-puzzle/pingus/pingus-0.7.6.ebuild b/games-puzzle/pingus/pingus-0.7.6.ebuild
new file mode 100644
index 000000000000..0a4ac7634642
--- /dev/null
+++ b/games-puzzle/pingus/pingus-0.7.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils scons-utils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="free Lemmings clone"
+HOMEPAGE="http://pingus.seul.org/"
+SRC_URI="http://pingus.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="opengl music"
+
+RDEPEND="media-libs/libsdl[joystick,opengl?,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ music? ( media-libs/sdl-mixer[mod] )
+ opengl? ( virtual/opengl )
+ media-libs/libpng:0=
+ dev-libs/boost:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ strip-flags
+ epatch \
+ "${FILESDIR}"/${P}-noopengl.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_compile() {
+ escons \
+ CXX="$(tc-getCXX)" \
+ CCFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ $(use_scons opengl with_opengl)
+}
+
+src_install() {
+ emake install-exec install-data \
+ DESTDIR="${D}" \
+ PREFIX="/usr" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ BINDIR="${GAMES_BINDIR}"
+ doman doc/man/pingus.6
+ doicon data/images/icons/pingus.svg
+ make_desktop_entry ${PN} Pingus
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}