summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/scramble
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/scramble')
-rw-r--r--games-puzzle/scramble/Manifest1
-rw-r--r--games-puzzle/scramble/metadata.xml5
-rw-r--r--games-puzzle/scramble/scramble-0.9.5.ebuild32
3 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/scramble/Manifest b/games-puzzle/scramble/Manifest
new file mode 100644
index 000000000000..4b86b376ee95
--- /dev/null
+++ b/games-puzzle/scramble/Manifest
@@ -0,0 +1 @@
+DIST scramble-0.9.5.tar.gz 552301 SHA256 9f0d27c65962f333f2a54294d1b42150aed0302fc12548a89c44d9f721d5d56f SHA512 ff361cefe842d6b2019a78571182fe35fc77a1332d6365211af7cf292da8532023bd565b7eed8b44545716474d441b0793253e856a1cad937f62396a5a29bd2b WHIRLPOOL 6361eed7868d79ed556cec368c439a534e08d3a4fd9ab4edd97a4af515f9fe1d2bcb92d8c972e0395755b33a5ca432e820a6a1e960f0003db237f97f4fdda81d
diff --git a/games-puzzle/scramble/metadata.xml b/games-puzzle/scramble/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/scramble/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/scramble/scramble-0.9.5.ebuild b/games-puzzle/scramble/scramble-0.9.5.ebuild
new file mode 100644
index 000000000000..3b88d008a965
--- /dev/null
+++ b/games-puzzle/scramble/scramble-0.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools flag-o-matic games
+
+DESCRIPTION="Create as many words as you can before the time runs out"
+HOMEPAGE="http://www.shiftygames.com/scramble/scramble.html"
+SRC_URI="http://www.shiftygames.com/scramble/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2[sound,video]
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[png]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}
+ sys-apps/miscfiles"
+
+src_prepare() {
+ append-cflags $(sdl-config --cflags)
+ eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}