summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-03-31 06:51:05 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-03-31 16:01:32 -0400
commit28b5997a8ad0e134c8231f2a42cd92df2a6b5785 (patch)
tree955bc3563ab0d82ca9dd3b4849d52d1f1da70a33 /games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
parentdev-db/sqlite: Stabilize arm64 wrt bug #574420 (diff)
downloadgentoo-28b5997a8ad0e134c8231f2a42cd92df2a6b5785.tar.gz
gentoo-28b5997a8ad0e134c8231f2a42cd92df2a6b5785.tar.bz2
gentoo-28b5997a8ad0e134c8231f2a42cd92df2a6b5785.zip
games-puzzle/sgt-puzzles: Version bump to 20160315
Adds support for GTK3. Adds flag to use icons packaged by NP-Hardass instead of bundled to bypass buggy colors in bundled icons. These repackaged icons are used regardless for the live ebuild as it does not ship with icons. Package-Manager: portage-2.2.26
Diffstat (limited to 'games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild')
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild77
1 files changed, 45 insertions, 32 deletions
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
index 8012c5d43060..6f1a68daa7aa 100644
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-99999999.ebuild
@@ -1,49 +1,67 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit eutils gnome2-utils toolchain-funcs games
+
+inherit eutils gnome2-utils toolchain-funcs games autotools
+
if [[ ${PV} == "99999999" ]] ; then
EGIT_REPO_URI="git://git.tartarus.org/simon/puzzles.git"
- inherit autotools git-r3
+ inherit git-r3
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-r${PV}.tar.gz"
- S=${WORKDIR}/puzzles-r${PV}
+ MAGIC=c0bc13c
+ SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/puzzles-${PV}.${MAGIC}.tar.gz"
+ S=${WORKDIR}/puzzles-${PV}.${MAGIC}
KEYWORDS="~amd64 ~x86"
fi
+GENTOO_ICONS="20160315"
+SRC_URI="${SRC_URI}
+ https://dev.gentoo.org/~np-hardass/distfiles/${PN}/${PN}-icons-${GENTOO_ICONS}.tar.xz
+"
+
DESCRIPTION="Simon Tatham's Portable Puzzle Collection"
HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
LICENSE="MIT"
SLOT="0"
-IUSE="doc"
+IUSE="doc gtk3 icons"
-RDEPEND="x11-libs/gtk+:2"
+RDEPEND="
+ !gtk3? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+"
DEPEND="${RDEPEND}
dev-lang/perl
virtual/pkgconfig
doc? ( >=app-doc/halibut-1.0 )"
+src_unpack() {
+ [[ ${PV} == "99999999" ]] && git-r3_src_unpack
+ unpack ${A}
+}
+
src_prepare() {
- if [[ ${PV} == "99999999" ]] ; then
- sed -i \
- -e 's/-O2 -Wall -Werror -ansi -pedantic -g//' \
- -e "s/libstr =/libstr = '\$(LDFLAGS) ' ./" \
- mkfiles.pl || die
- ./mkfiles.pl || die
- eautoreconf
- else
- sed -i \
- -e 's:= -O2 -Wall -Werror -ansi -pedantic -g:= $(CPPFLAGS):' \
- -e '/LDFLAGS/s:=:=$(LDFLAGS) :' \
- Makefile || die
+ sed -i \
+ -e 's/-O2 -Wall -Werror -ansi -pedantic -g//' \
+ -e "s/libstr =/libstr = '\$(LDFLAGS) ' ./" \
+ mkfiles.pl || die
+ ./mkfiles.pl || die
+ eautoreconf
+
+ # Import icons from latest Gentoo tarball
+ if [[ ${PV} == "99999999" ]] || use icons; then
+ cp -R ../${PN}-icons/icons . || die
fi
}
+src_configure() {
+ econf --with-gtk=$(usex gtk3 3 2)
+}
+
src_compile() {
emake CC="$(tc-getCC)"
if use doc ; then
@@ -53,7 +71,7 @@ src_compile() {
src_install() {
dodir "${GAMES_BINDIR}"
- emake DESTDIR="${D}" gamesdir="${GAMES_BINDIR}" install
+ emake DESTDIR="${D}" bindir="${GAMES_BINDIR}" install
dodoc README
local file name
@@ -61,19 +79,14 @@ src_install() {
[[ ${file} == "nullgame.R" ]] && continue
name=$(awk -F: '/exe:/ { print $3 }' "${file}")
file=${file%.R}
- if [[ ${PV} -lt 99999999 ]] ; then
- newicon -s 48 icons/${file}-48d24.png ${PN}-${file}.png
- make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
- else
- # No icons with the live version
- make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}"
- fi
+ newicon -s 48 icons/${file}-48d24.png ${PN}-${file}.png
+ make_desktop_entry "${GAMES_BINDIR}/${file}" "${name}" "${PN}-${file}"
done
if use doc ; then
dohtml *.html
- doinfo puzzles.info
- dodoc puzzles.pdf puzzles.ps puzzles.txt puzzles.chm
+ doinfo puzzles.info{,-1,-2,-3}
+ dodoc puzzles.pdf puzzles.ps puzzles.txt
fi
prepgamesdirs
@@ -81,14 +94,14 @@ src_install() {
pkg_preinst() {
games_pkg_preinst
- [[ ${PV} -lt 99999999 ]] && gnome2_icon_savelist
+ gnome2_icon_savelist
}
pkg_postinst() {
games_pkg_postinst
- [[ ${PV} -lt 99999999 ]] && gnome2_icon_cache_update
+ gnome2_icon_cache_update
}
pkg_postrm() {
- [[ ${PV} -lt 99999999 ]] && gnome2_icon_cache_update
+ gnome2_icon_cache_update
}