summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-07-08 00:55:50 +0200
committerUlrich Müller <ulm@gentoo.org>2018-07-08 00:56:24 +0200
commit88d8489cdf74c37c0fe6435486e6cbfcf65bbbdd (patch)
treef049a196f931797e09c26481a9cc49c4e966571d /games-puzzle/world-of-goo
parentapp-arch/innoextract: Drop old (diff)
downloadgentoo-88d8489cdf74c37c0fe6435486e6cbfcf65bbbdd.tar.gz
gentoo-88d8489cdf74c37c0fe6435486e6cbfcf65bbbdd.tar.bz2
gentoo-88d8489cdf74c37c0fe6435486e6cbfcf65bbbdd.zip
games-puzzle/world-of-goo: Don't inherit games.eclass.
Bump EAPI to 6. Fix DISTDIR usage in pkg_nofetch. Closes: https://bugs.gentoo.org/659334 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/world-of-goo')
-rw-r--r--games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild (renamed from games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild)27
1 files changed, 13 insertions, 14 deletions
diff --git a/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild b/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild
index b941fe96f8d3..51f7f12ff569 100644
--- a/games-puzzle/world-of-goo/world-of-goo-1.41-r1.ebuild
+++ b/games-puzzle/world-of-goo/world-of-goo-1.41-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=6
+
+inherit desktop eutils # eutils for make_wrapper()
DESCRIPTION="A puzzle game with a strong emphasis on physics"
HOMEPAGE="http://2dboy.com/"
@@ -18,8 +19,7 @@ fi
LICENSE="2dboy-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="fetch strip"
+RESTRICT="fetch bindist strip"
RDEPEND="media-libs/libsdl[alsa,sound,opengl,video]
media-libs/sdl-mixer[vorbis]
@@ -27,10 +27,9 @@ RDEPEND="media-libs/libsdl[alsa,sound,opengl,video]
virtual/opengl
virtual/glu
>=sys-devel/gcc-3.4"
-DEPEND=""
-S=${WORKDIR}/${MY_PN}
-dir=${GAMES_PREFIX_OPT}/${PN}
+S="${WORKDIR}/${MY_PN}"
+dir="/opt/${PN}"
QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
${dir:1}/${MY_PN%Demo}.bin64"
@@ -38,9 +37,10 @@ QA_PREBUILT="${dir:1}/${MY_PN%Demo}.bin32
pkg_nofetch() {
if [[ ${PN} == *-demo ]] ; then
elog "To download the demo, visit http://worldofgoo.com/dl2.php?lk=demo"
- elog "and download ${A} and place it in ${DISTDIR}"
+ elog "and download ${A} and place it in your DISTDIR directory."
else
- elog "Download ${A} from ${HOMEPAGE} and place it in ${DISTDIR}"
+ elog "Download ${A} from ${HOMEPAGE}"
+ elog "and place it in your DISTDIR directory."
fi
}
@@ -48,7 +48,7 @@ src_install() {
exeinto "${dir}"
doexe ${MY_PN%Demo}{,.$(usex amd64 bin64 bin32)}
- games_make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
+ make_wrapper ${PN} "${dir}"/${MY_PN%Demo}
insinto "${dir}"
doins -r icons properties res
@@ -61,7 +61,6 @@ src_install() {
fi
dodoc linux-issues.txt
- dohtml readme.html
-
- prepgamesdirs
+ docinto html
+ dodoc readme.html
}