summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 18:10:20 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:59 +0200
commit18578843f3abb1e80076764bcbf7b62993444d0e (patch)
treedfbce0a659502dc298a1e02a0d7fa12a6e43aca8 /games-puzzle/xtris
parentgames-puzzle/xpired: Drop old (diff)
downloadgentoo-18578843f3abb1e80076764bcbf7b62993444d0e.tar.gz
gentoo-18578843f3abb1e80076764bcbf7b62993444d0e.tar.bz2
gentoo-18578843f3abb1e80076764bcbf7b62993444d0e.zip
games-puzzle/xtris: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/xtris')
-rw-r--r--games-puzzle/xtris/xtris-1.15-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/xtris/xtris-1.15-r1.ebuild b/games-puzzle/xtris/xtris-1.15-r1.ebuild
new file mode 100644
index 000000000000..1c863a9b1d17
--- /dev/null
+++ b/games-puzzle/xtris/xtris-1.15-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit desktop toolchain-funcs
+
+DESCRIPTION="A networked Tetris-like game"
+HOMEPAGE="http://www.iagora.com/~espel/xtris/xtris.html"
+SRC_URI="http://www.iagora.com/~espel/xtris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ BINDIR=/usr/bin \
+ MANDIR=/usr/share/man \
+ CFLAGS="${CFLAGS}" \
+ EXTRALIBS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xtris xtserv xtbot
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} xtris ${PN}
+ doman xtris.6 xtserv.6 xtbot.6
+ dodoc ChangeLog PROTOCOL README
+}