summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-29 23:43:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-12-29 23:45:54 +0200
commit979beea22f428225b0fccf740f0db25013c5948b (patch)
tree4dacc3e0e919524c42d7d8778249d56dda3d467a /games-puzzle/xye/files
parentdev-games/vamos: Version bump to 0.8.2 (diff)
downloadgentoo-979beea22f428225b0fccf740f0db25013c5948b.tar.gz
gentoo-979beea22f428225b0fccf740f0db25013c5948b.tar.bz2
gentoo-979beea22f428225b0fccf740f0db25013c5948b.zip
games-puzzle/xye: Version bump to 0.12.2
Gentoo-bug: 600298 * EAPI=6 * Remove games.eclass Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'games-puzzle/xye/files')
-rw-r--r--games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch45
-rw-r--r--games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch14
-rw-r--r--games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch18
3 files changed, 77 insertions, 0 deletions
diff --git a/games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch b/games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch
new file mode 100644
index 000000000000..c96d42e34681
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.2-fix-buildsystem.patch
@@ -0,0 +1,45 @@
+Fix build system to respect correct paths
+and install files in correct paths.
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4,13 +4,11 @@
+
+
+ bin_PROGRAMS = xye
+-xye_LDFLAGS =
+
++doc_DATA = NEWS ChangeLog AUTHORS
++html_DATA = ReadMe.html
+
+-docedir = $(datadir)/@PACKAGE@
+-doce_DATA = ReadMe.html NEWS ChangeLog AUTHORS
+-
+-levelsdir= $(datadir)/@PACKAGE@/levels
++levelsdir= $(datadir)/$(PACKAGE)/levels
+ levels_DATA = levels/5levels.xye \
+ levels/levels.xye \
+ levels/logo.xye \
+@@ -25,12 +23,10 @@
+ levels/xyester.xye \
+ levels/SuperJustin.xye
+
+-resdir= $(datadir)/@PACKAGE@/res
++resdir= $(datadir)/$(PACKAGE)/res
+ res_DATA = res/default.xml \
+ res/xye.png \
+ res/xye_luminosity.png \
+-res/DejaVuSans.ttf \
+-res/DejaVuSans-Bold.ttf \
+ res/fon.bmp \
+ res/fon_bold.bmp \
+ res/clean40.xml \
+@@ -103,7 +99,7 @@
+ src/skins.cpp \
+ src/skins.h
+
+-EXTRA_DIST = ${EXTRA_DIST1} ${xye_SOURCES} ${res_DATA} ${levels_DATA} ${doce_DATA}
++EXTRA_DIST = ${EXTRA_DIST1} ${xye_SOURCES} ${res_DATA} ${levels_DATA}
+
+ DEFS=@data_path_flag@
+
diff --git a/games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch b/games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch
new file mode 100644
index 000000000000..f2083b871a82
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.2-fix-c++14.patch
@@ -0,0 +1,14 @@
+Add explicit cast to silence C++14 -Wnarrowing conversion warnings.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=600298
+
+--- a/src/xsb_level.cpp
++++ b/src/xsb_level.cpp
+@@ -784,7 +784,7 @@
+
+ bool FromXyeDFS(int* mem, unsigned char x, unsigned char y)
+ {
+- static const unsigned char dx[4] = {0,0,-1,1}, dy[4] = {-1,1,0,0};
++ static const unsigned char dx[4] = {0,0,(unsigned char)-1,1}, dy[4] = {(unsigned char)-1,1,0,0};
+ int &res = mem[y*XYE_HORZ+x];
+ if( res==0)
+ {
diff --git a/games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch b/games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch
new file mode 100644
index 000000000000..99558ef28732
--- /dev/null
+++ b/games-puzzle/xye/files/xye-0.12.2-fix-desktop-file.patch
@@ -0,0 +1,18 @@
+Fix .desktop file to comply with FDO specifications.
+
+--- a/xye.desktop
++++ b/xye.desktop
+@@ -4,11 +4,11 @@
+ Encoding=UTF-8
+ Exec=xye
+ Type=Application
+-Categories=Application;Game;PuzzleGame
++Categories=Game
+ Name=Xye
+ GenericName=Xye
+ Comment=Solve puzzles and action challenges in order to get all the gems in the room.
+ Terminal=false
+ StartupNotify=false
+-Icon=xye.png
++Icon=xye
+ MimeType=application/xye-xml