summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 14:31:16 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:33:20 +0200
commit0103fbd77542af2a771b2eb9df24d982fb3202f9 (patch)
treee96ca030ac23d1817762cb535a38d1d93769a2e4 /games-puzzle
parentgames-puzzle/lpairs: Drop old (diff)
downloadgentoo-0103fbd77542af2a771b2eb9df24d982fb3202f9.tar.gz
gentoo-0103fbd77542af2a771b2eb9df24d982fb3202f9.tar.bz2
gentoo-0103fbd77542af2a771b2eb9df24d982fb3202f9.zip
games-puzzle/ltris: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ltris/ltris-1.0.19-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/ltris/ltris-1.0.19-r1.ebuild b/games-puzzle/ltris/ltris-1.0.19-r1.ebuild
new file mode 100644
index 000000000000..9f3d02d2cc06
--- /dev/null
+++ b/games-puzzle/ltris/ltris-1.0.19-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop flag-o-matic
+
+DESCRIPTION="Very polished Tetris clone"
+HOMEPAGE="http://lgames.sourceforge.net/LTris/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ mv configure.in configure.ac || die
+ AT_M4DIR=m4 eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #570966)
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon icons/ltris48.xpm ${PN}.xpm
+ make_desktop_entry ltris LTris
+}