summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-15 17:02:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-30 23:07:52 +0200
commit128d253494c94840403eb5688f501f5a090e2989 (patch)
treec63d6be176ded560a76644b6a6545400cc6cd22b /games-puzzle
parentsci-electronics/librepcb: bump version to 0.1.5 (diff)
downloadgentoo-128d253494c94840403eb5688f501f5a090e2989.tar.gz
gentoo-128d253494c94840403eb5688f501f5a090e2989.tar.bz2
gentoo-128d253494c94840403eb5688f501f5a090e2989.zip
games-puzzle/sgt-puzzles: EAPI-7 bump, drop IUSE=gtk3, fix menu entry
Use desktop.eclass, xdg-utils.eclass Thanks-to: Simon <sur3@gmx.de> Bug: https://bugs.gentoo.org/656490 Bug: https://bugs.gentoo.org/769167 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/sgt-puzzles/sgt-puzzles-20190415.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/games-puzzle/sgt-puzzles/sgt-puzzles-20190415.ebuild b/games-puzzle/sgt-puzzles/sgt-puzzles-20190415.ebuild
index 2988d396d974..902b9c928920 100644
--- a/games-puzzle/sgt-puzzles/sgt-puzzles-20190415.ebuild
+++ b/games-puzzle/sgt-puzzles/sgt-puzzles-20190415.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils gnome2-utils toolchain-funcs autotools
+inherit autotools desktop toolchain-funcs xdg-utils
if [[ ${PV} == "99999999" ]] ; then
inherit git-r3
@@ -22,16 +22,17 @@ HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/puzzles/"
LICENSE="MIT"
SLOT="0"
-IUSE="+doc gtk3"
+IUSE="+doc"
COMMON_DEPEND="
- !gtk3? ( x11-libs/gtk+:2 )
- gtk3? ( x11-libs/gtk+:3 )"
+ x11-libs/gtk+:3"
RDEPEND="${COMMON_DEPEND}
x11-misc/xdg-utils" # Used by builtin help patch
-DEPEND="${COMMON_DEPEND}
+DEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
dev-lang/perl
virtual/pkgconfig
doc? ( >=app-doc/halibut-1.2 )"
@@ -67,7 +68,7 @@ src_prepare() {
src_configure() {
econf \
--program-prefix="${PN}_" \
- --with-gtk=$(usex gtk3 3 2)
+ --with-gtk=3
}
src_compile() {
@@ -86,12 +87,12 @@ src_install() {
name=$(awk -F: '/exe:/ { print $3 }' "${file}")
file=${file%.R}
newicon -s 48 icons/${file}-48d24.png ${PN}_${file}.png
- make_desktop_entry "${PN}_${file}" "${name}" "${PN}_${file}" "Game;LogicGame;X-${PN};"
+ make_desktop_entry "${PN}_${file}" "${name}" "${PN}_${file}" "LogicGame;X-${PN};"
done
if use doc ; then
- DOCS=( puzzles.{pdf,ps,txt} )
- HTML_DOCS=( *.html )
+ local DOCS=( puzzles.{pdf,ps,txt} )
+ local HTML_DOCS=( *.html )
einstalldocs
doinfo puzzles.info{,-1,-2,-3}
fi
@@ -102,14 +103,10 @@ src_install() {
doins "${FILESDIR}/${PN}.directory"
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}