summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-09 07:18:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-09 07:26:34 -0400
commit1c717da145549d35dd267860e242bff77ade4780 (patch)
tree15d56e15a1aced5098107b3bdffb0752d5b01507 /games-puzzle
parentsci-mathematics/maxima: depend on >=emacs-26 (diff)
downloadgentoo-1c717da145549d35dd267860e242bff77ade4780.tar.gz
gentoo-1c717da145549d35dd267860e242bff77ade4780.tar.bz2
gentoo-1c717da145549d35dd267860e242bff77ade4780.zip
games-puzzle/biniax2: fix -fno-common, EAPI-7 bump
Also: - update SRC_URI - don't call gcc directly - revbump for [sound,video] to libsdl (game crashes without both) Thanks to Samuel Bauer for -fno-common fix Closes: https://bugs.gentoo.org/795078 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/biniax2/biniax2-1.30-r2.ebuild49
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-build.patch9
-rw-r--r--games-puzzle/biniax2/files/biniax2-1.30-fno-common.patch17
3 files changed, 66 insertions, 9 deletions
diff --git a/games-puzzle/biniax2/biniax2-1.30-r2.ebuild b/games-puzzle/biniax2/biniax2-1.30-r2.ebuild
new file mode 100644
index 000000000000..719216968d73
--- /dev/null
+++ b/games-puzzle/biniax2/biniax2-1.30-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Logic game with arcade and tactics modes"
+HOMEPAGE="http://biniax.com/"
+SRC_URI="http://www.tuzsuzov.com/biniax/${P}-fullsrc.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-dotfiles.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ rm data/Thumbs.db || die
+
+ sed -i "s|data/|/usr/share/${PN}/|" desktop/{gfx,snd}.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r data/.
+
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry ${PN} Biniax-2
+}
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-build.patch b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
index cce8abe91a93..168ba6bfa794 100644
--- a/games-puzzle/biniax2/files/biniax2-1.30-build.patch
+++ b/games-puzzle/biniax2/files/biniax2-1.30-build.patch
@@ -1,14 +1,5 @@
--- a/makefile
+++ b/makefile
-@@ -4,7 +4,7 @@
- # To execute the game you need the runtimes of SDL, SDL_mixer and SDL_image.
-
- FLAGS=-W -WALL
--CC=gcc
-+CC?=gcc
- FILES=biniax.c hof.c desktop/cfg.c desktop/gfx.c desktop/snd.c desktop/inp.c desktop/sys.c
- INCLUDES=-I . -I desktop
- LINKTO=-lSDL -lSDL_mixer -lSDL_image
@@ -12,4 +12,4 @@
TARGET=biniax2
diff --git a/games-puzzle/biniax2/files/biniax2-1.30-fno-common.patch b/games-puzzle/biniax2/files/biniax2-1.30-fno-common.patch
new file mode 100644
index 000000000000..73206f0c78d8
--- /dev/null
+++ b/games-puzzle/biniax2/files/biniax2-1.30-fno-common.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/795078
+--- a/desktop/inp.c
++++ b/desktop/inp.c
+@@ -37,4 +37,5 @@
+ ******************************************************************************/
+
++BNX_INP _Inp;
+
+ BNX_BOOL inpInit()
+--- a/desktop/inp.h
++++ b/desktop/inp.h
+@@ -70,5 +70,4 @@
+ } BNX_INP;
+
+-BNX_INP _Inp;
+
+ /******************************************************************************