summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 14:56:37 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:33:37 +0200
commit436b0f14374585f2af0b15da4b73d7319e19d241 (patch)
treeb72470f9b1c2b08bcbd7defeb880c7093127987a /games-puzzle
parentgames-puzzle/mirrormagic: Drop old (diff)
downloadgentoo-436b0f14374585f2af0b15da4b73d7319e19d241.tar.gz
gentoo-436b0f14374585f2af0b15da4b73d7319e19d241.tar.bz2
gentoo-436b0f14374585f2af0b15da4b73d7319e19d241.zip
games-puzzle/monsterz: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch4
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch4
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild47
3 files changed, 51 insertions, 4 deletions
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
index 8e55b23a327c..d0847d6c2c10 100644
--- a/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
@@ -1,5 +1,5 @@
---- monsterz.py
-+++ monsterz.py
+--- a/monsterz.py
++++ b/monsterz.py
@@ -829,10 +829,10 @@
pass
else:
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
index 652450bf190b..6920e0e36971 100644
--- a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
@@ -1,5 +1,5 @@
---- monsterz.py.orig 2006-05-12 18:55:51.000000000 -0400
-+++ monsterz.py 2006-05-12 18:57:44.000000000 -0400
+--- a/monsterz.py.orig 2006-05-12 18:55:51.000000000 -0400
++++ b/monsterz.py 2006-05-12 18:57:44.000000000 -0400
@@ -1907,7 +1906,7 @@
print ' (C) Mike Kershaw <dragorn@kismetwireless.net>'
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild
new file mode 100644
index 000000000000..4cff31b75f8c
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1-r4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop python-r1
+
+DESCRIPTION="A little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="GPL-1+ LGPL-2+ WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-blit.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:/usr/share/${PN}:" \
+ monsterz.py || die "sed failed"
+ rm Makefile || die
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r graphics sound
+ newbin monsterz.py ${PN}
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ einstalldocs
+ python_replicate_script "${ED%/}"/usr/bin/monsterz
+}