summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 21:33:19 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 21:33:19 -0500
commit60d4e86f9939458f0d41e5bd606702ba2c27b3d1 (patch)
tree745cbbedbec62e6107e425c09861bdfa2ff00134 /games-puzzle
parentuse epatch to apply patch (diff)
downloadgentoo-60d4e86f9939458f0d41e5bd606702ba2c27b3d1.tar.gz
gentoo-60d4e86f9939458f0d41e5bd606702ba2c27b3d1.tar.bz2
gentoo-60d4e86f9939458f0d41e5bd606702ba2c27b3d1.zip
use epatch to apply patch
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/picpuz/picpuz-2.5.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-puzzle/picpuz/picpuz-2.5.ebuild b/games-puzzle/picpuz/picpuz-2.5.ebuild
index 5fb2ece89725..7fd732e7714c 100644
--- a/games-puzzle/picpuz/picpuz-2.5.ebuild
+++ b/games-puzzle/picpuz/picpuz-2.5.ebuild
@@ -18,7 +18,11 @@ RDEPEND="x11-libs/gtk+:3"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-build.patch "${FILESDIR}"/${P}-pthread-underlinking.patch )
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-pthread-underlinking.patch
+}
src_compile() {
emake \