summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-05-23 09:05:50 +0200
committerUlrich Müller <ulm@gentoo.org>2023-05-23 09:58:36 +0200
commitfe39371f860060a5b540dddd2900e8297b562308 (patch)
tree500113365b598d8598849a603d8191e447e31aaa /games-puzzle
parentdev-python/trove-classifiers: Stabilize 2023.5.2 ALLARCHES, #906966 (diff)
downloadgentoo-fe39371f860060a5b540dddd2900e8297b562308.tar.gz
gentoo-fe39371f860060a5b540dddd2900e8297b562308.tar.bz2
gentoo-fe39371f860060a5b540dddd2900e8297b562308.zip
games-puzzle/ltris: Install highscore file in /var/games
Update to EAPI 8. Closes: https://bugs.gentoo.org/682898 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ltris/ltris-1.0.19-r2.ebuild (renamed from games-puzzle/ltris/ltris-1.0.19-r1.ebuild)23
1 files changed, 15 insertions, 8 deletions
diff --git a/games-puzzle/ltris/ltris-1.0.19-r1.ebuild b/games-puzzle/ltris/ltris-1.0.19-r2.ebuild
index 6355966fbbf4..33bc89d9f495 100644
--- a/games-puzzle/ltris/ltris-1.0.19-r1.ebuild
+++ b/games-puzzle/ltris/ltris-1.0.19-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools desktop flag-o-matic
DESCRIPTION="Very polished Tetris clone"
@@ -14,28 +14,35 @@ KEYWORDS="~amd64 ~x86"
IUSE="nls"
RDEPEND="
+ acct-group/gamestat
media-libs/libsdl[video]
media-libs/sdl-mixer
nls? ( virtual/libintl )
"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_prepare() {
default
- eapply "${FILESDIR}"/${P}-gentoo.patch
- mv configure.in configure.ac || die
AT_M4DIR=m4 eautoreconf
append-cflags -std=gnu89 # build with gcc5 (bug #570966)
}
src_configure() {
- econf $(use_enable nls)
+ econf \
+ --localstatedir="${EPREFIX}"/var/games \
+ $(use_enable nls)
}
src_install() {
default
+
+ fowners 0:gamestat /usr/bin/${PN} /var/games/${PN}.hscr
+ fperms g+s /usr/bin/${PN}
+ fperms 664 /var/games/${PN}.hscr
+
newicon icons/ltris48.xpm ${PN}.xpm
make_desktop_entry ltris LTris
}