summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-12-19 17:22:20 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-04 02:12:14 +0100
commit3c050a702c41ebdc685cb3ee0ae2877449e03b0a (patch)
treed795d8d0d0f5e8bb6481f9a6107e700029d30ee8 /games-roguelike/FTL-gog
parentx11-terms/terminology: remove old (diff)
downloadgentoo-3c050a702c41ebdc685cb3ee0ae2877449e03b0a.tar.gz
gentoo-3c050a702c41ebdc685cb3ee0ae2877449e03b0a.tar.bz2
gentoo-3c050a702c41ebdc685cb3ee0ae2877449e03b0a.zip
games-roguelike/FTL-gog: bump version to 1.6.9.25330
Signed-off-by: Rob Levitsky <kitsunenokenja@protonmail.ch> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10667 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-roguelike/FTL-gog')
-rw-r--r--games-roguelike/FTL-gog/FTL-gog-1.6.9.25330.ebuild63
-rw-r--r--games-roguelike/FTL-gog/Manifest1
2 files changed, 64 insertions, 0 deletions
diff --git a/games-roguelike/FTL-gog/FTL-gog-1.6.9.25330.ebuild b/games-roguelike/FTL-gog/FTL-gog-1.6.9.25330.ebuild
new file mode 100644
index 000000000000..d06484d8ce7f
--- /dev/null
+++ b/games-roguelike/FTL-gog/FTL-gog-1.6.9.25330.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker
+
+DESCRIPTION="Top-down roguelike space ship simulator"
+HOMEPAGE="https://www.gog.com/game/faster_than_light"
+SRC_URI="ftl_advanced_edition_${PV//./_}.sh"
+RESTRICT="bindist fetch mirror strip test"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+BDEPEND="app-arch/unzip"
+RDEPEND="media-libs/freetype
+ media-libs/libsdl[X,sound,opengl,video]
+ media-libs/libpng
+ sys-libs/zlib
+ virtual/opengl"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from"
+ elog "https://www.gog.com/game/faster_than_light"
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${A}"
+}
+
+src_prepare() {
+ default
+ rm -r support/{xdg*,*.{sh,txt}} || die
+ if ! use x86; then
+ rm game/data/FTL.x86 || die
+ fi
+ if ! use amd64; then
+ rm game/data/FTL.amd64 || die
+ fi
+
+ sed -i start.sh -e '/chmod/d' || die
+}
+
+src_install() {
+ insinto /opt/gog/FTL
+ doins -r .
+ fperms +x /opt/gog/FTL/{start.sh,game/FTL,game/data/FTL}
+
+ if use x86; then
+ fperms +x /opt/gog/FTL/game/data/FTL.x86
+ fi
+ if use amd64; then
+ fperms +x /opt/gog/FTL/game/data/FTL.amd64
+ fi
+
+ make_desktop_entry "/opt/gog/FTL/start.sh" "FTL: Advanced Edition" FTL
+ newicon support/icon.png FTL.png
+}
diff --git a/games-roguelike/FTL-gog/Manifest b/games-roguelike/FTL-gog/Manifest
index bf66610bb8f4..01ad988f5007 100644
--- a/games-roguelike/FTL-gog/Manifest
+++ b/games-roguelike/FTL-gog/Manifest
@@ -1 +1,2 @@
DIST ftl_advanced_edition_1_6_8_24110.sh 201034290 BLAKE2B 6ed07bcbcacaf81704682be438ae8bfa4ccfe906e2845ad25550b081d33964f8c3d6f40326a56168b072e99e0c30190579bcd756f8a3c055a5b54907a0913014 SHA512 ad66211ad077738797d0a8f33bc43c01dbcd6bdff3e4d9a8316e0ebca06a94b76380911e54c4b16dfc2f836cdbb6a025383714f0de4b9f9c19376660a695c678
+DIST ftl_advanced_edition_1_6_9_25330.sh 200833898 BLAKE2B 9eb048e302158f1cc040492a9fb5bd84038dd9202b8cfdd08ec50a3e55326da18048f4eab0c8b79ecf47229d54b59fca46cebaa107d253eadc0cc5659da4792b SHA512 7b1d87b5def455989290366ef80652361dee9d0fd2838806d2386d8a1df44e0ab125c5538aa07b20382be4aa3054b14b4a489b39b6aa252f3cc00ead8504186c