summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-roguelike/angband
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-roguelike/angband')
-rw-r--r--games-roguelike/angband/Manifest2
-rw-r--r--games-roguelike/angband/angband-3.4.1.ebuild100
-rw-r--r--games-roguelike/angband/angband-3.5.1.ebuild98
-rw-r--r--games-roguelike/angband/metadata.xml8
4 files changed, 208 insertions, 0 deletions
diff --git a/games-roguelike/angband/Manifest b/games-roguelike/angband/Manifest
new file mode 100644
index 000000000000..e146ae8dbbbe
--- /dev/null
+++ b/games-roguelike/angband/Manifest
@@ -0,0 +1,2 @@
+DIST angband-v3.4.1.tar.gz 17880537 SHA256 461e36d22c15df330b4d4eaa850e4f2c2da6731d23e99fa13a056249343fd945 SHA512 76099c8fa999e88ea1324bb70b4dee5df1faccd1fa256cc0c460ce2c5ddae9634fdef876bd0d826e99e6dcc54a9f9cf619d82552dc658d0115b97e0e644c19d3 WHIRLPOOL 4e74092deb1868a7c172c206058ebf198f5bdf08f50ebfa5cd3a4a4200998283d9d1896ff39f41fa88f74b78940bee16a3f8a2ce949a69b3e01417017cc32545
+DIST angband-v3.5.1.tar.gz 20539732 SHA256 c5ca3ab75fd820a49eb2b9ab8b1c2a811ff992276f9800cc61c686e90bd4d447 SHA512 a45a64b4de1161f327594b93177432c22a00301e7e6058a5e9c1407343c4448217564303578d46f3ea15c94b86aeaf813685a04a70a5dae58511cbf0427b86dc WHIRLPOOL b5f32d90b9923c8ea00eae762b3e743f3d1175290feb5bd38064a29954e8685545eb2129eabcb98e2386f7d425c9ce966c8824634844d23dd91dbbd8b32586bd
diff --git a/games-roguelike/angband/angband-3.4.1.ebuild b/games-roguelike/angband/angband-3.4.1.ebuild
new file mode 100644
index 000000000000..7d383dc83f8b
--- /dev/null
+++ b/games-roguelike/angband/angband-3.4.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator games
+
+MAJOR_PV=$(get_version_component_range 1-2)
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R. Tolkien"
+HOMEPAGE="http://rephial.org/"
+SRC_URI="http://rephial.org/downloads/${MAJOR_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ncurses sdl +sound X"
+
+RDEPEND="X? ( x11-libs/libX11 )
+ !ncurses? ( !X? ( !sdl? ( sys-libs/ncurses ) ) )
+ ncurses? ( sys-libs/ncurses )
+ sdl? ( media-libs/libsdl[video,X]
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ sound? ( media-libs/sdl-mixer
+ media-libs/libsdl[sound] ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( changes.txt faq.txt readme.txt thanks.txt )
+
+src_prepare() {
+ # fix paths
+ sed -i \
+ -e '/libpath/s#datarootdir#datadir#' \
+ -e '/X_PRE_LIBS/s:-lSM -lICE::' \
+ configure || die
+
+ sed -i \
+ -e "/^.SILENT/d" \
+ mk/buildsys.mk.in || die
+}
+
+src_configure() {
+ local myconf
+
+ if use sdl; then
+ myconf="$(use_enable sound sdl-mixer)"
+ else
+ myconf="--disable-sdl-mixer"
+ fi
+
+ egamesconf \
+ --bindir="${GAMES_BINDIR}" \
+ --with-private-dirs \
+ $(use_enable X x11) \
+ $(use_enable sdl) \
+ $(use_enable ncurses curses) \
+ $(use !sdl && use !ncurses && use !X && \
+ echo --enable-curses) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ # Edit files are now system config files in Angband, but
+ # users will be hidden from applying updates by default
+ echo "CONFIG_PROTECT_MASK=\"${GAMES_SYSCONFDIR}/${PN}/edit/\"" \
+ > "${T}"/99${PN}
+ doenvd "${T}"/99${PN} || die
+
+ # Create desktop entries if required.
+ ICON_LOC="${GAMES_DATADIR}/${PN}/xtra/icon/att-32.png"
+ if use X; then
+ make_desktop_entry "angband -mx11" "Angband (X11)" "${ICON_LOC}"
+ fi
+
+ if use sdl; then
+ make_desktop_entry "angband -msdl" "Angband (SDL)" "${ICON_LOC}"
+ fi
+
+ use ncurses || rm -rf "${D}${GAMES_DATADIR}/${PN}/xtra/graf"
+ use sound || rm -rf "${D}${GAMES_DATADIR}/${PN}/xtra/sound"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ elog "Angband now uses private savefiles instead of system-wide ones"
+ elog "This version of Angband is not compatible with the save files"
+ elog "of previous versions"
+ echo
+
+ games_pkg_postinst
+}
diff --git a/games-roguelike/angband/angband-3.5.1.ebuild b/games-roguelike/angband/angband-3.5.1.ebuild
new file mode 100644
index 000000000000..a3cbb867a40f
--- /dev/null
+++ b/games-roguelike/angband/angband-3.5.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils versionator games
+
+MAJOR_PV=$(get_version_component_range 1-2)
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="A roguelike dungeon exploration game based on the books of J.R.R. Tolkien"
+HOMEPAGE="http://rephial.org/"
+SRC_URI="http://rephial.org/downloads/${MAJOR_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="ncurses sdl +sound X"
+
+RDEPEND="X? ( x11-libs/libX11 )
+ !ncurses? ( !X? ( !sdl? ( sys-libs/ncurses ) ) )
+ ncurses? ( sys-libs/ncurses )
+ sdl? ( media-libs/libsdl[video,X]
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ sound? ( media-libs/sdl-mixer[mp3]
+ media-libs/libsdl[sound] ) )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix paths
+ sed -i \
+ -e '/libpath/s#datarootdir#datadir#' \
+ -e '/X_PRE_LIBS/s:-lSM -lICE::' \
+ configure || die
+
+ sed -i \
+ -e "/^.SILENT/d" \
+ mk/buildsys.mk.in || die
+}
+
+src_configure() {
+ local myconf
+
+ if use sdl; then
+ myconf="$(use_enable sound sdl-mixer)"
+ else
+ myconf="--disable-sdl-mixer"
+ fi
+
+ egamesconf \
+ --bindir="${GAMES_BINDIR}" \
+ --with-private-dirs \
+ $(use_enable X x11) \
+ $(use_enable sdl) \
+ $(use_enable ncurses curses) \
+ $(use !sdl && use !ncurses && use !X && \
+ echo --enable-curses) \
+ ${myconf}
+}
+
+src_install() {
+ DOCS=( changes.txt faq.txt readme.txt thanks.txt )
+
+ default
+
+ # Edit files are now system config files in Angband, but
+ # users will be hidden from applying updates by default
+ echo "CONFIG_PROTECT_MASK=\"${GAMES_SYSCONFDIR}/${PN}/edit/\"" \
+ > "${T}"/99${PN}
+ doenvd "${T}"/99${PN} || die
+
+ # Create desktop entries if required.
+ ICON_LOC="${GAMES_DATADIR}/${PN}/xtra/icon/att-32.png"
+ if use X; then
+ make_desktop_entry "angband -mx11" "Angband (X11)" "${ICON_LOC}"
+ fi
+
+ if use sdl; then
+ make_desktop_entry "angband -msdl" "Angband (SDL)" "${ICON_LOC}"
+ fi
+
+ use ncurses || rm -rf "${D}${GAMES_DATADIR}/${PN}/xtra/graf"
+ use sound || rm -rf "${D}${GAMES_DATADIR}/${PN}/xtra/sound"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ echo
+ elog "Angband now uses private savefiles instead of system-wide ones"
+ elog "This version of Angband is not compatible with the save files"
+ elog "of previous versions"
+ echo
+
+ games_pkg_postinst
+}
diff --git a/games-roguelike/angband/metadata.xml b/games-roguelike/angband/metadata.xml
new file mode 100644
index 000000000000..b8e6986601e2
--- /dev/null
+++ b/games-roguelike/angband/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='sound'>Enable and install sounds</flag>
+ </use>
+</pkgmetadata>