summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-roguelike/scourge
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-roguelike/scourge')
-rw-r--r--games-roguelike/scourge/Manifest2
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch11
-rw-r--r--games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch12
-rw-r--r--games-roguelike/scourge/metadata.xml8
-rw-r--r--games-roguelike/scourge/scourge-0.21.1.ebuild60
5 files changed, 93 insertions, 0 deletions
diff --git a/games-roguelike/scourge/Manifest b/games-roguelike/scourge/Manifest
new file mode 100644
index 000000000000..bb26d6d76849
--- /dev/null
+++ b/games-roguelike/scourge/Manifest
@@ -0,0 +1,2 @@
+DIST scourge-0.21.1.data.tar.gz 142093436 SHA256 13f33735ff814eb465d95355dcaaf2cdd16a3329f85aeab1a97ad40919cd1f12 SHA512 3701aba0f70d71aeb0e185e808e34cea62a637809a9b4c14fd19bdfbf91d36cf8dafa2a4cfddc3ee493827b40eea657fcdddc8277c57a635bc8ca8e3286376be WHIRLPOOL 7764cc3f01fd8083db243e96de8b2c9aad778d64442aa81a7e4bfb2e7f4dd17faa7cb6ec97b2329e37145342b56af931c64514f4e661be5a2243d6980586cf42
+DIST scourge-0.21.1.src.tar.gz 8146157 SHA256 e5d3dc784bc117a3fe2f4449c74cb896310760ae5a82a50f8c1045705416cef3 SHA512 e530a8f7bddc1969a02a8b9a8b272f6f60d2c4830d23d96fc671cb79a2c4097fb9c5c0c262004a8157448b601bf58f9bbff95dd6d98275a28d3d404c339ce2ad WHIRLPOOL 58f275515dd1e345059ab79a920ee974733009c26d862ddaa20e29353fb059ba54bf282dda582f05fb66c77bcbcdeb3d3d70975a274550ba2817e1ea996a0ab0
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch b/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch
new file mode 100644
index 000000000000..44b817e55cb3
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- scourge-0.21.1.src/scourge/configure.in
++++ scourge-0.21.1.src/scourge/configure.in
+@@ -4,7 +4,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(src/scourge.h)
+ AM_INIT_AUTOMAKE(scourge, "0.21")
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+
+ dnl internationalization macros
+ AC_GNU_SOURCE
diff --git a/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch b/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
new file mode 100644
index 000000000000..50c5cac32934
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.21.1-gcc47.patch
@@ -0,0 +1,12 @@
+--- src/squirrel/squtils.h.old 2012-08-30 18:06:43.474037926 +0200
++++ src/squirrel/squtils.h 2012-08-30 18:14:13.300261523 +0200
+@@ -8,6 +8,9 @@
+ #define SQ_FREE(__ptr,__size) sq_vm_free(__ptr,__size);
+ #define SQ_REALLOC(__ptr,__oldsize,__size) sq_vm_realloc(__ptr,__oldsize,__size);
+
++void *sq_vm_realloc(void *p,SQUnsignedInteger oldsize,SQUnsignedInteger size);
++void sq_vm_free(void *p,SQUnsignedInteger size);
++
+ //sqvector mini vector class, supports objects by value
+ template<typename T> class sqvector
+ {
diff --git a/games-roguelike/scourge/metadata.xml b/games-roguelike/scourge/metadata.xml
new file mode 100644
index 000000000000..f243e01d74db
--- /dev/null
+++ b/games-roguelike/scourge/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">scourge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-roguelike/scourge/scourge-0.21.1.ebuild b/games-roguelike/scourge/scourge-0.21.1.ebuild
new file mode 100644
index 000000000000..88523d8f7583
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.21.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils wxwidgets games
+
+DESCRIPTION="A graphical rogue-like adventure game"
+HOMEPAGE="http://scourgeweb.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz
+ mirror://sourceforge/${PN}/${P}.data.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/glu
+ virtual/opengl
+ media-libs/freetype:2
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # bug #257601
+ sed -i \
+ -e '/AC_CHECK_HEADERS.*glext/ s:):, [#include <GL/gl.h>] ):' \
+ configure.in \
+ || die "sed failed"
+ sed -i \
+ -e '/snprintf/s/tmp, 256/tmp, sizeof(tmp)/' \
+ src/scourgehandler.cpp || die
+ epatch "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --with-data-dir="${GAMES_DATADIR}"/${PN} \
+ --localedir=/usr/share/locale
+}
+
+src_install() {
+ default
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../scourge_data/*
+ doicon assets/scourge.png
+ make_desktop_entry scourge S.C.O.U.R.G.E.
+ prepgamesdirs
+}