summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-03-28 21:53:01 -0400
committerPatrice Clement <monsieurp@gentoo.org>2018-04-02 23:20:33 +0200
commit3499912f322e54d99e599175a6e1f0e50bf27238 (patch)
tree8af09592a0f2899c9b58dc74e7ad5fb44a5bb9c0 /games-roguelike
parentapp-crypt/zulucrypt: fix build with USE=-qt5. (diff)
downloadgentoo-3499912f322e54d99e599175a6e1f0e50bf27238.tar.gz
gentoo-3499912f322e54d99e599175a6e1f0e50bf27238.tar.bz2
gentoo-3499912f322e54d99e599175a6e1f0e50bf27238.zip
games-roguelike/FTL-gog: version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7665
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild61
-rw-r--r--games-roguelike/FTL-gog/Manifest1
2 files changed, 62 insertions, 0 deletions
diff --git a/games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild b/games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild
new file mode 100644
index 000000000000..513747171d91
--- /dev/null
+++ b/games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop unpacker
+
+DESCRIPTION="Top-down roguelike space ship simulator"
+HOMEPAGE="https://www.gog.com/game/faster_than_light"
+SRC_URI="ftl_advanced_edition_en_${PV//./_}.sh"
+RESTRICT="bindist fetch mirror strip test"
+
+LICENSE="GOG-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="media-libs/freetype
+ media-libs/libsdl[X,sound,opengl,video]
+ media-libs/libpng
+ sys-libs/zlib
+ virtual/opengl"
+
+S="${WORKDIR}/data/noarch"
+
+pkg_nofetch() {
+ elog "Please buy and download ${SRC_URI} from"
+ elog "https://www.gog.com/game/faster_than_light"
+}
+
+src_unpack() {
+ unpack_zip "${DISTDIR}/${A}"
+}
+
+src_prepare() {
+ default
+ rm -r support/{xdg*,*.{sh,txt}} || die
+ if ! use x86; then
+ rm game/data/FTL.x86 || die
+ fi
+ if ! use amd64; then
+ rm game/data/FTL.amd64 || die
+ fi
+}
+
+src_install() {
+ insinto /opt/gog/FTL
+ doins -r .
+ fperms +x /opt/gog/FTL/{start.sh,game/FTL}
+
+ if use x86; then
+ fperms +x /opt/gog/FTL/game/data/FTL.x86
+ fi
+ if use amd64; then
+ fperms +x /opt/gog/FTL/game/data/FTL.amd64
+ fi
+
+ make_desktop_entry "/opt/gog/FTL/start.sh" "FTL: Advanced Edition" FTL
+ newicon support/icon.png FTL.png
+}
diff --git a/games-roguelike/FTL-gog/Manifest b/games-roguelike/FTL-gog/Manifest
index 0833ae5534ba..c0a81c7c7f71 100644
--- a/games-roguelike/FTL-gog/Manifest
+++ b/games-roguelike/FTL-gog/Manifest
@@ -1 +1,2 @@
DIST ftl_advanced_edition_en_1_6_3_17917.sh 190333601 BLAKE2B 18fb43da1718524fcdecbde9d9cbfbed84db6e5b3a49abbec9b331d13f9ce7ca807633f3ad126badba9e92278b264ab3de47efabbf772180a35c108ce07268f1 SHA512 6cc3770d9a3d9ac301d79eaee0b88d3d4bbf90186356d443f53d4e894b4cdefd36c080e23506d76e0a3f7e15267e3e206469872cc7b29ddeaa20d520b9dfddd0
+DIST ftl_advanced_edition_en_1_6_7_18662.sh 190506416 BLAKE2B 0a628e4de3a5539add2f421377c32ead5397ad1709e30124aa8c9d0874b98eb37cda97873b21dbb78fe635769c1a3c3254988ae22494805409d28f5e33417e44 SHA512 3e9c08d32964e21b49ad3e1b6a17c2349d516fdbea4118518e022134affc43dd27d2e60eea94784096aea4725f2656b43f6b6be9fe02eaed743c167ef842d66b