summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-02-11 02:41:09 +0200
committerJames Le Cuirot <chewi@gentoo.org>2019-02-12 22:01:26 +0000
commit87873260e20e28328606357a3bf8c41eeae87dbb (patch)
tree3aebdce7a024218cdc5a01a796ae66793ae8cd22 /games-roguelike
parentnet-wireless/unifi: bump to 5.10.15, drop old (diff)
downloadgentoo-87873260e20e28328606357a3bf8c41eeae87dbb.tar.gz
gentoo-87873260e20e28328606357a3bf8c41eeae87dbb.tar.bz2
gentoo-87873260e20e28328606357a3bf8c41eeae87dbb.zip
games-roguelike/moria: fix build with sys-libs/ncurses[tinfo]
Closes: https://bugs.gentoo.org/677672 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11025 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/moria/files/moria-5.7.10-tinfo.patch24
-rw-r--r--games-roguelike/moria/moria-5.7.10.ebuild5
2 files changed, 28 insertions, 1 deletions
diff --git a/games-roguelike/moria/files/moria-5.7.10-tinfo.patch b/games-roguelike/moria/files/moria-5.7.10-tinfo.patch
new file mode 100644
index 000000000000..5173a7d00f4e
--- /dev/null
+++ b/games-roguelike/moria/files/moria-5.7.10-tinfo.patch
@@ -0,0 +1,24 @@
+From aa3ebbd2eb4b4a6ab92833060c212255d90c68b4 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <stefan.strogin@gmail.com>
+Date: Mon, 11 Feb 2019 01:53:10 +0200
+Subject: [PATCH] Find NCurses library on Linux/Mac
+
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 372d838..f39ebcd 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -261,6 +261,7 @@ elseif ((MSYS OR MINGW) AND NOT "$ENV{MINGW}" STREQUAL "")
+ set(CURSES_LIBRARIES "/$ENV{MINGW}/lib/libncurses.a")
+ else ()
+ message(STATUS "NOTE: Configuring build for macOS/Linux release...")
++ set(CURSES_NEED_NCURSES TRUE)
+ find_package(Curses REQUIRED)
+ endif ()
+
+--
+2.20.1
+
diff --git a/games-roguelike/moria/moria-5.7.10.ebuild b/games-roguelike/moria/moria-5.7.10.ebuild
index 77fadf27a040..999c073daa4f 100644
--- a/games-roguelike/moria/moria-5.7.10.ebuild
+++ b/games-roguelike/moria/moria-5.7.10.ebuild
@@ -21,7 +21,10 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/umoria-${PV}"
-PATCHES=( "${FILESDIR}/${P}-gentoo-paths.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo-paths.patch"
+ "${FILESDIR}/${P}-tinfo.patch"
+)
pkg_setup(){
enewgroup gamestat 36