summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Scharrer <daniel@constexpr.org>2016-03-24 23:05:41 +0100
committerMichael Palimaka <kensington@gentoo.org>2016-03-26 00:19:27 +1100
commitc7714fc8e0edbe83fb8bf307c1ef137a11dc75fa (patch)
treed64641cc66cd8c2741992dfe40524cc9a74f2c22 /games-rpg/arx-libertatis
parentkde-apps: Move kdeedu-meta 15.12.3 from kde overlay (diff)
downloadgentoo-c7714fc8e0edbe83fb8bf307c1ef137a11dc75fa.tar.gz
gentoo-c7714fc8e0edbe83fb8bf307c1ef137a11dc75fa.tar.bz2
gentoo-c7714fc8e0edbe83fb8bf307c1ef137a11dc75fa.zip
games-rpg/arx-libertatis: fix build with cmake 3.5
Diffstat (limited to 'games-rpg/arx-libertatis')
-rw-r--r--games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild6
-rw-r--r--games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch34
2 files changed, 39 insertions, 1 deletions
diff --git a/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild b/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild
index d238e63a52fe..578e102b37d7 100644
--- a/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild
+++ b/games-rpg/arx-libertatis/arx-libertatis-1.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,6 +36,10 @@ DEPEND="${COMMON_DEPEND}
DOCS=( README.md AUTHORS CHANGELOG )
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-3.5.patch
+)
+
src_configure() {
# editor does not build
local mycmakeargs=(
diff --git a/games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch b/games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch
new file mode 100644
index 000000000000..d085afafe393
--- /dev/null
+++ b/games-rpg/arx-libertatis/files/arx-libertatis-1.1.2-cmake-3.5.patch
@@ -0,0 +1,34 @@
+From c4262bc600dc01d3ddbacc7811132b29ea46ad3b Mon Sep 17 00:00:00 2001
+From: Daniel Scharrer <daniel@constexpr.org>
+Date: Thu, 24 Mar 2016 22:47:44 +0100
+Subject: [PATCH] CMake: Disable variable expansion for quoted strings in if()
+
+This makes the build system more robust against stray variables
+coming from included CMake scripts provided by the system.
+
+Fixes build with CMake 3.5.
+
+This has been fixed in master with commit 60e43c.
+---
+ CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 93f1ee3..8347544 100755
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,6 +13,11 @@ else()
+ cmake_minimum_required(VERSION 2.8)
+ endif()
+
++if(POLICY CMP0054)
++ # CMake 3.1+: Only interpret if() arguments as variables or keywords when unquoted.
++ cmake_policy(SET CMP0054 NEW)
++endif()
++
+
+ # Define configuration options
+
+--
+2.7.4
+