summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/eternal-lands/eternal-lands-1.9.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/eternal-lands/eternal-lands-1.9.3.ebuild')
-rw-r--r--games-rpg/eternal-lands/eternal-lands-1.9.3.ebuild154
1 files changed, 154 insertions, 0 deletions
diff --git a/games-rpg/eternal-lands/eternal-lands-1.9.3.ebuild b/games-rpg/eternal-lands/eternal-lands-1.9.3.ebuild
new file mode 100644
index 000000000000..cf86f7bdb3f3
--- /dev/null
+++ b/games-rpg/eternal-lands/eternal-lands-1.9.3.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="An online MMORPG written in C and SDL"
+HOMEPAGE="http://www.eternal-lands.com"
+SRC_URI="mirror://gentoo/elc_1.9.3-20120213.tar.bz2
+ http://dev.gentoo.org/~rich0/distfiles/eternal-lands.png"
+
+LICENSE="eternal_lands"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug doc kernel_linux"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X]
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/openal
+ media-libs/freealut
+ media-libs/libvorbis
+ dev-libs/libxml2
+ media-libs/cal3d[-16bit-indices]
+ media-libs/libpng
+ >=games-rpg/eternal-lands-data-1.9.2"
+
+DEPEND="${RDEPEND}
+ >=app-eselect/eselect-opengl-1.0.6-r1
+ app-arch/unzip
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )"
+
+#ECVS_SERVER="cvs.elc.berlios.de:/cvsroot/elc"
+#ECVS_MODULE="elc"
+#ECVS_USER="anonymous"
+#ECVS_LOCALNAME="elc"
+#ECVS_PASS=""
+#ECVS_CVS_OPTIONS="-dP -z3"
+#ECVS_BRANCH="elc_1_8_0"
+
+#S="${WORKDIR}/${ECVS_MODULE}"
+S="${WORKDIR}/elc"
+
+src_unpack() {
+# cvs_src_unpack
+ OPTIONS="-DDATA_DIR="\\\\\"${GAMES_DATADIR}/${PN}/\\\\\"""
+ S_CLIENT="${WORKDIR}/elc"
+ BROWSER="firefox"
+ unpack ${A}
+ cd "${S}"
+}
+
+src_prepare() {
+ # Add debugging options
+ if use debug ; then
+ OPTIONS="${OPTIONS} -DMEMORY_DEBUG"
+ append-flags -ggdb
+ fi
+
+ # Clean compile flags (make Gentoo friendly)
+ sed -i \
+ -e "s@CFLAGS=\$(PLATFORM) \$(CWARN) -O0 -ggdb -pipe@CFLAGS = ${CFLAGS} ${OPTIONS} @g" \
+ -e "s@CXXFLAGS=\$(PLATFORM) \$(CXXWARN) -O0 -ggdb -pipe@CXXFLAGS = ${CXXFLAGS} ${OPTIONS} @g" \
+ -e 's/lopenal/lopenal -l alut/' \
+ Makefile.linux || die "sed failed"
+
+ sed -i \
+ -e 's/#browser/browser/g' \
+ -e "s/browser = mozilla/#browser = ${BROWSER}/g" \
+ -e "s@#data_dir = /usr/local/games/el/@#data_dir = ${GAMES_DATADIR}/${PN}/@g" \
+ el.ini || die "sed failed"
+
+ # Support BSD in the Linux makefile - it's easier
+ use kernel_linux || sed -i \
+ -e 's/^CFLAGS=.*/& -DBSD/' \
+ Makefile.linux || die "sed failed"
+
+ # Clean up library flag order for --as-needed
+# sed -i -e 's/@$(LINK) $(CFLAGS) $(LDFLAGS) -o $(EXE) $(OBJS)/@$(LINK) $(CFLAGS) -o $(EXE) $(OBJS) $(LDFLAGS)/' Makefile.linux
+
+ # Finally, update the server
+ sed -i -e '/#server_address =/ s/.*/#server_address = game.eternal-lands.com/' \
+ el.ini || die "sed failed"
+
+ sed -i -e 's:FEATURES:EL_FEATURES:' make.defaults
+ sed -i -e 's:FEATURES:EL_FEATURES:' Makefile.linux
+
+ if use debug; then
+ sed -i -e 's/#\(EL_FEATURES += MEMORY_DEBUG\)/\1/' make.defaults
+ sed -i -e 's/#\(EL_FEATURES += MEMORY_DEBUG\)/\1/' Makefile.linux
+ fi
+
+ cp Makefile.linux Makefile
+
+ epatch "${FILESDIR}/${PN}-1.9.2-glext.patch"
+# epatch "${FILESDIR}/${PN}-1.9.1-libpng.patch"
+
+# Fix for Gentoo zlib OF redefine
+
+ sed -i '1i#define OF(x) x' `find -name "*.c"` || die "sed failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ if use doc; then
+ emake docs || die "Failed to create documentation, try with USE=-doc"
+ mv ./docs/html/ ../client || die "Failed to move documentation directory"
+ fi
+}
+
+src_install() {
+ doicon "${DISTDIR}/eternal-lands.png" ${PN}.png
+
+ newgamesbin el.x86.linux.bin el \
+ || die "newgamesbin failed"
+ make_desktop_entry el "Eternal Lands" \
+ || die "make_desktop_entry failed"
+ insopts -m 0660
+ insinto "${GAMES_DATADIR}/${PN}"
+
+ doins -r *.ini *.txt commands.lst \
+ || die "doins failed"
+
+ if use doc ; then
+ dohtml -r client/*
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "Auto Update is now enabled in Eternal Lands"
+ elog "If an update occurs then the client will suddenly exit"
+ elog "Updates only happen when the game first loads"
+ elog "Please don't report this behaviour as a bug"
+
+ # Ensure that the files are writable by the game group for auto
+ # updating.
+ chmod -R g+rw "${ROOT}/${GAMES_DATADIR}/${PN}"
+
+ # Make sure new files stay in games group
+ find "${ROOT}/${GAMES_DATADIR}/${PN}" -type d -exec chmod g+sx {} \;
+
+}