summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/mana/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/mana/files')
-rw-r--r--games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch53
-rw-r--r--games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch24
-rw-r--r--games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch26
-rw-r--r--games-rpg/mana/files/mana-0.6.1-gentoo.patch71
4 files changed, 174 insertions, 0 deletions
diff --git a/games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch b/games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch
new file mode 100644
index 000000000000..6cd99bf4262c
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-Fix-missing-virtual-destructors-and-guichan-use.patch
@@ -0,0 +1,53 @@
+From b5dc2de418d6d06cce31d786862c5f548171a097 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 28 Jul 2012 15:52:35 +0200
+Subject: [PATCH 1/3] Fix missing virtual destructors and guichan use.
+
+---
+ src/gui/widgets/tabbedarea.h | 3 ++-
+ src/gui/widgets/textfield.h | 1 +
+ src/resources/itemdb.h | 2 +-
+ 3 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/gui/widgets/tabbedarea.h b/src/gui/widgets/tabbedarea.h
+index 45b092a..b43078a 100644
+--- a/src/gui/widgets/tabbedarea.h
++++ b/src/gui/widgets/tabbedarea.h
+@@ -98,7 +98,8 @@ class TabbedArea : public gcn::TabbedArea, public gcn::WidgetListener
+ int getContainerHeight() const
+ { return mWidgetContainer->getHeight(); }
+
+- using gcn::TabbedArea::setSelectedTab;
++ void setSelectedTab(unsigned int index)
++ { gcn::TabbedArea::setSelectedTab(index); }
+
+ void setSelectedTab(gcn::Tab *tab);
+
+diff --git a/src/gui/widgets/textfield.h b/src/gui/widgets/textfield.h
+index 2865403..94cada4 100644
+--- a/src/gui/widgets/textfield.h
++++ b/src/gui/widgets/textfield.h
+@@ -63,6 +63,7 @@ struct TextHistory {
+
+ class AutoCompleteLister {
+ public:
++ virtual ~AutoCompleteLister() {}
+ virtual void getAutoCompleteList(std::vector<std::string>&) const {}
+ };
+
+diff --git a/src/resources/itemdb.h b/src/resources/itemdb.h
+index 1531108..d7859ad 100644
+--- a/src/resources/itemdb.h
++++ b/src/resources/itemdb.h
+@@ -78,7 +78,7 @@ class ItemDB
+ mLoaded(false)
+ {}
+
+- ~ItemDB()
++ virtual ~ItemDB()
+ {}
+
+ /**
+--
+1.7.11.1
+
diff --git a/games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch b/games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch
new file mode 100644
index 000000000000..b7ab39d05cdc
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-Import-cstdint-for-int64_t.patch
@@ -0,0 +1,24 @@
+From dfd304e93bb9010ef8226ee4d026d45c9bf9d2f5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 28 Jul 2012 15:54:57 +0200
+Subject: [PATCH 3/3] Import cstdint for int64_t.
+
+---
+ src/net/download.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/net/download.h b/src/net/download.h
+index c0bdf20..b9ad17e 100644
+--- a/src/net/download.h
++++ b/src/net/download.h
+@@ -18,6 +18,7 @@
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <cstdint>
+ #include <cstdio>
+ #include <string>
+
+--
+1.7.11.1
+
diff --git a/games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch b/games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch
new file mode 100644
index 000000000000..fa752383c38a
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-Trick-gcc-into-importing-C99-stdint.h-when-C-11-is-n.patch
@@ -0,0 +1,26 @@
+From bb92108fed0242f1a3509384faeb2234d007c05e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 28 Jul 2012 15:54:10 +0200
+Subject: [PATCH 2/3] Trick gcc into importing C99 stdint.h when C++11 is not
+ used.
+
+---
+ src/cpp0x_compat/cstdint | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/cpp0x_compat/cstdint b/src/cpp0x_compat/cstdint
+index d8d71d9..d430649 100644
+--- a/src/cpp0x_compat/cstdint
++++ b/src/cpp0x_compat/cstdint
+@@ -5,3 +5,8 @@
+ * compiles Mana fine so it apparently understands types like uint16_t by
+ * default.
+ */
++
++extern "C"
++{
++#include <stdint.h>
++};
+--
+1.7.11.1
+
diff --git a/games-rpg/mana/files/mana-0.6.1-gentoo.patch b/games-rpg/mana/files/mana-0.6.1-gentoo.patch
new file mode 100644
index 000000000000..561336e421c5
--- /dev/null
+++ b/games-rpg/mana/files/mana-0.6.1-gentoo.patch
@@ -0,0 +1,71 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Jun 30 20:48:23 UTC 2012
+Subject: build system
+
+use system fonts
+
+make datadir and bindir paths modifiable
+https://github.com/mana/mana/commit/02a7b2aa739cd0cf5a855f0a78b91d9fd5ad4385
+don't overwrite system/environment CXXFLAGS
+https://github.com/mana/mana/commit/2305ca095bee6b32c930f71b99d4c1205ceb561b
+add option to use system enet headers
+https://github.com/mana/mana/commit/d754a64e3839b3888d489046546195792e4ecc34
+
+--- data/CMakeLists.txt.old 2011-08-02 12:15:38.520030381 +0200
++++ data/CMakeLists.txt 2011-08-02 12:15:44.971029615 +0200
+@@ -1,6 +1,5 @@
+ SET(DATA_DIR ${PKG_DATADIR}/data)
+
+-ADD_SUBDIRECTORY(fonts)
+ ADD_SUBDIRECTORY(graphics)
+ ADD_SUBDIRECTORY(help)
+ ADD_SUBDIRECTORY(icons)
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -42,9 +42,9 @@
+ IF (NOT OSX AND NOT BEOS)
+ OPTION(USE_X11 "Use X11 Clipboard functionality" ON)
+ ENDIF ()
+- SET(PKG_DATADIR ${CMAKE_INSTALL_PREFIX}/share/mana)
++ SET(PKG_DATADIR ${CMAKE_INSTALL_PREFIX}/share/mana CACHE PATH "Mana datadir")
+ SET(LOCALEDIR ${CMAKE_INSTALL_PREFIX}/share/locale)
+- SET(PKG_BINDIR ${CMAKE_INSTALL_PREFIX}/bin)
++ SET(PKG_BINDIR ${CMAKE_INSTALL_PREFIX}/bin CACHE PATH "Mana bindir")
+ ENDIF (WIN32)
+
+ ADD_SUBDIRECTORY(data)
+--- src/CMakeLists.txt
++++ src/CMakeLists.txt
+@@ -12,7 +12,7 @@
+
+ IF (CMAKE_COMPILER_IS_GNUCXX)
+ # Help getting compilation warnings
+- SET(CMAKE_CXX_FLAGS "-Wall")
++ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
+ IF (WIN32)
+ # This includes enough debug information to get something useful
+ # from Dr. Mingw while keeping binary size down. Almost useless
+--- libs/enet/CMakeLists.txt
++++ libs/enet/CMakeLists.txt
+@@ -1,3 +1,7 @@
++INCLUDE(FindPkgConfig)
++
++OPTION(WITH_BUNDLEDHEADERS "Use bundled enet headers" ON)
++
+ INCLUDE(CheckFunctionExists)
+ CHECK_FUNCTION_EXISTS(gethostbyaddr_r HAS_GETHOSTBYNAME_R)
+ IF(HAS_GETHOSTBYNAME_R EQUAL 1)
+@@ -49,7 +53,12 @@
+ win32.c
+ )
+
+-INCLUDE_DIRECTORIES("include")
++IF (WITH_BUNDLEDHEADERS)
++ INCLUDE_DIRECTORIES("include")
++ELSE (WITH_BUNDLEDHEADERS)
++ PKG_CHECK_MODULES(ENET REQUIRED libenet)
++ INCLUDE_DIRECTORIES("${ENET_INCLUDEDIR}")
++ENDIF()
+
+ ADD_LIBRARY(enet STATIC ${SRCS})
+ IF (BEOS)