summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-18 10:03:14 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-18 10:04:55 +0200
commit17bc41c55ba74ad2a5b372bdec9d46e7077c8bb2 (patch)
tree0a6323fb414a732ef6b881995625de77c16baadb /games-rpg/manaplus
parentmedia-libs/mesa: add mulilib use dependencies for libunwind (diff)
downloadgentoo-17bc41c55ba74ad2a5b372bdec9d46e7077c8bb2.tar.gz
gentoo-17bc41c55ba74ad2a5b372bdec9d46e7077c8bb2.tar.bz2
gentoo-17bc41c55ba74ad2a5b372bdec9d46e7077c8bb2.zip
games-rpg/manaplus: Bump to version 1.7.5.14
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'games-rpg/manaplus')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.5.14.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index 3f12df3276b7..189f0b93b329 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.7.4.15.tar.xz 14796748 SHA256 d6916bdc2587747bfe7fc2b1b67ae6e88284613a9f0001e2b6ccf2b8b40d3734 SHA512 c97f849c047ec37ae0a6a445b5a520e441fd452c2e7e0e3ae0a2a494a88027c1cf34c4f7dc860b811e58dac5b2e165d231fc4fbf22defe9a241291caa4762b23 WHIRLPOOL bf76c3de7663d4f08906962b7df6421e9f4495b85166dc68b31da8641a4d07f8a25c82482f3b94b40cebb20a47ff806a3b39300335828b6a603f25a27911795d
DIST manaplus-1.7.4.29.tar.xz 14816088 SHA256 08048156c97255b1b1311a912c6b7224a7f7ade2d2bfaee0375968ee843b5f48 SHA512 0ba95ee6f9f3b18e53bc61047b4a5779faf76c9eb88d49e7f2e171cd13fc211c574d02e8b38b3e6a382bfa82e28db37d7908058054bd7a010615fabbf6dd2c7d WHIRLPOOL e7a654ebd350efda80321c32ba3395f0b5099d4e25725e84fdb01a3a0421aa3bf19c012c025cc3a74c8eaaec94fedf978e15e33467ae5699569d4e21a1463255
+DIST manaplus-1.7.5.14.tar.xz 14813736 SHA256 9019e48a19c47674355ae7524f513e45785a05be166e8a302d93e536653ab8ac SHA512 4c95554c590cc8b96bcd66f528e26b184ff3f9c60230130b092731a8b310bb64ee8fdeab44c0415b7cf9b81ed5ab9aca90ff3b167e895413c0139c1909c44c37 WHIRLPOOL fb36cdbae6f15dd65104b64a58e24f083fcb50bc26d6219d1d4984d0114a1a846e72055a7b7fbcfef72a9a44477956ad81a3d876c9d225186a1460851fbd6262
diff --git a/games-rpg/manaplus/manaplus-1.7.5.14.ebuild b/games-rpg/manaplus/manaplus-1.7.5.14.ebuild
new file mode 100644
index 000000000000..7896a6774aff
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.5.14.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ CONFIG_SHELL=/bin/bash \
+ econf \
+ --localedir=/usr/share/locale \
+ --without-internalsdlgfx \
+ $(use_with mumble) \
+ $(use_enable nls) \
+ $(use_with opengl) \
+ --enable-libxml=$(usex pugixml pugixml libxml) \
+ $(use_with sdl2) \
+ $(use_enable test unittests)
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}