summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/tmw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/tmw')
-rw-r--r--games-rpg/tmw/Manifest1
-rw-r--r--games-rpg/tmw/files/tmw-branding-20130201-gentoo.patch20
-rw-r--r--games-rpg/tmw/metadata.xml8
-rw-r--r--games-rpg/tmw/tmw-20130201.ebuild60
4 files changed, 89 insertions, 0 deletions
diff --git a/games-rpg/tmw/Manifest b/games-rpg/tmw/Manifest
new file mode 100644
index 000000000000..7d2e81d92d37
--- /dev/null
+++ b/games-rpg/tmw/Manifest
@@ -0,0 +1 @@
+DIST tmw-branding-20130201.tar.gz 1146207 SHA256 251692f120c54fba4323191239a4a2022aa58a5de220531e06b634fc25097c69 SHA512 65ff615ef8a715192416b80393341d76423a8b2a27609e9388fcdec0b4e3552398857b33585690de5fded9f792c5dbfceb631cf834e68dcc8906d48097a21a99 WHIRLPOOL 87af806a49f2017149e8e84ad8c682a6ed72c5fd87ad8f0fa5c9ebc407ddc0400b89a9a0cc40ca33716a7a1e82daaec102007764848302a8c94d5c17182d2018
diff --git a/games-rpg/tmw/files/tmw-branding-20130201-gentoo.patch b/games-rpg/tmw/files/tmw-branding-20130201-gentoo.patch
new file mode 100644
index 000000000000..b671d149a8c2
--- /dev/null
+++ b/games-rpg/tmw/files/tmw-branding-20130201-gentoo.patch
@@ -0,0 +1,20 @@
+--- tmw-branding-20130201/tmw
++++ tmw-branding-20130201/tmw
+@@ -1,2 +1,2 @@
+ #!/bin/sh
+-exec manaplus /usr/share/tmw/tmw.mana "$@"
++exec manaplus @GENTOO_DATADIR@/tmw.mana "$@"
+--- tmw-branding-20130201/tmw.desktop
++++ tmw-branding-20130201/tmw.desktop
+@@ -8,9 +8,9 @@
+ Comment[it]=Un gioco fantasy online
+ Comment[nl]=Een online role playing game
+ Comment[sv]=Ett fantasyrollspel online
+-Exec=manaplus /usr/share/tmw/tmw.mana
++Exec=manaplus @GENTOO_DATADIR@/tmw.mana
+ StartupNotify=false
+ Terminal=false
+ Type=Application
+ Icon=tmw
+-Categories=Application;Game;
++Categories=Game;
diff --git a/games-rpg/tmw/metadata.xml b/games-rpg/tmw/metadata.xml
new file mode 100644
index 000000000000..4304bc88a6fe
--- /dev/null
+++ b/games-rpg/tmw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">themanaworld</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-rpg/tmw/tmw-20130201.ebuild b/games-rpg/tmw/tmw-20130201.ebuild
new file mode 100644
index 000000000000..2119ddcf18b2
--- /dev/null
+++ b/games-rpg/tmw/tmw-20130201.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+MY_PN=${PN}-branding
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Branding for the Mana client for server.themanaworld.org"
+HOMEPAGE="http://themanaworld.org/"
+SRC_URI="mirror://sourceforge/themanaworld/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="games-rpg/manaplus"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${MY_P}-gentoo.patch
+
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ ${PN} ${PN}.desktop \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN}
+
+ insinto "${GAMES_DATADIR}/${PN}/"
+ doins ${PN}.mana
+ doins -r data/
+
+ domenu ${PN}.desktop
+
+ doicon -s 32 data/icons/${PN}.xpm
+ doicon data/icons/${PN}.png
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}