summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <sokolov@google.com>2020-10-17 23:54:32 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-10-22 22:18:19 +0100
commit24ab5599bcad574f7d3c89bbc2cbb0d371b434a6 (patch)
treef1cd97cc26218def99cb3c8de30866a4cfb5a130 /games-rpg
parentgames-util/grfcodec: Fix build failure with GCC 10 (diff)
downloadgentoo-24ab5599bcad574f7d3c89bbc2cbb0d371b434a6.tar.gz
gentoo-24ab5599bcad574f7d3c89bbc2cbb0d371b434a6.tar.bz2
gentoo-24ab5599bcad574f7d3c89bbc2cbb0d371b434a6.zip
games-rpg/adonthell: don't call ar directly
Closes: https://bugs.gentoo.org/746095 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/17961 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/adonthell/adonthell-0.3.8.ebuild11
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.8-ar.patch11
2 files changed, 21 insertions, 1 deletions
diff --git a/games-rpg/adonthell/adonthell-0.3.8.ebuild b/games-rpg/adonthell/adonthell-0.3.8.ebuild
index ee5853868fc4..5407912c96c2 100644
--- a/games-rpg/adonthell/adonthell-0.3.8.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.8.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+inherit autotools python-single-r1
DESCRIPTION="Roleplaying game engine"
HOMEPAGE="http://adonthell.nongnu.org/"
@@ -37,6 +37,15 @@ BDEPEND="
DOCS=( AUTHORS NEWBIE NEWS README )
+PATCHES=(
+ "${FILESDIR}/${P}-ar.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
pkg_setup() {
python-single-r1_pkg_setup
}
diff --git a/games-rpg/adonthell/files/adonthell-0.3.8-ar.patch b/games-rpg/adonthell/files/adonthell-0.3.8-ar.patch
new file mode 100644
index 000000000000..2b2e34d62c7d
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.8-ar.patch
@@ -0,0 +1,11 @@
+diff -r b3fec744fc29 configure.ac
+--- a/configure.ac Sat Oct 17 22:39:45 2020 +0000
++++ b/configure.ac Sat Oct 17 22:40:17 2020 +0000
+@@ -26,6 +26,7 @@
+ AC_PROG_CXXCPP
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
++AM_PROG_AR
+
+ dnl ****
+ dnl i18n